Support

Account

Home Forums Backend Issues (wp-admin) Database Won't Update

Solving

Database Won't Update

    • ltol

    • October 23, 2018 at 3:35 am

    Hello,
    I recently updated ACF to the latest version and got the “Database Upgrade Required” notification. I backed up the db, and tried running the upgrade, but it will not go through. I tried leaving it for over an hour. It just hangs on the “Reading upgrade tasks…”. Is there another way to upgrade the db and get rid of the upgrade message in WP?

    • Helma

    • October 23, 2018 at 6:37 pm

    Hi, I have the same issue on one of our sites. would be great to get a hint on how to resolve.
    Thanks!

  • I have the same problem, and all custom fields are gone from the WordPress backend. The fields are still working on the website though. I disabled all other plugins, increased the memory limit, and no there were no debug errors found. The upgrade still won’t complete.

    I completed the database upgrade on another site in a few seconds. I haven’t heard back from support on this for a few days.

    • akaadan

    • October 31, 2018 at 7:23 am

    Same issue here. Can’t edit or do anything with the pro field groups until I upgrade the DB and when I do, it gets stuck at “Reading upgrade tasks…”. Please help.

  • I heard back from support. They suggested switching themes, but my site’s custom theme has to be kept online. They also suggested disabling Jetpack, but it hasn’t fixed the problem.

    I’m going to try increasing the memory limit again. If it doesn’t work, I’ll just downgrade. Here are the instructions if anyone needs them. Scroll down to Troubleshooting.

    https://www.advancedcustomfields.com/resources/upgrade-guide-version-5/

  • Update: I increased the memory limit in wp-config to 2GB, rolled back to version 5.6.10 then ran the database upgrade, and it worked. Just increasing the memory limit didn’t work.

    I upgraded the plugin to the latest version after that, and everything is ok. Custom fields are back in the WordPress backend.

    • xnau

    • December 17, 2018 at 6:55 am

    Hi, I’m seeing this problem too, wondering if anyone has figured out what the issue is.

    I see there is a possible workaround, but that doesn’t explain the problem. I want to understand what the problem is before I try to fix it.

    Anybody seeing any error messages associated with the upgrade attempt?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.