Home Forums Backend Issues (wp-admin) Data Erases From Fields


Data Erases From Fields

  • Hello,

    I’ve noticed the past couple of days that some information has been disappearing from custom fields associated with categories. As an example. I have a category “Brands” with a few custom fields like “Brand Description”, “Brand Logo”, and various social networking urls. I have noticed a couple of these categories completely erasing those fields, but the standard WP fields remain intact. I have seen this happen in a few different parent categories.

    I have been doing a major overhaul of the sites taxonomies (moving some categories into custom taxonomies) but I don’t think that should have any effect on the still active categories.

    I recently updated to version 4.3.8, maybe a week ago or so.

    So, I was wondering, is this a bug with ACF? Or is this a Db thing? Or what the heck is going on?

    Thank you in advance for any insight you may give. It’s just the weirdest damn thing.

  • I noticed a similar issue happening to me. I lost field groups multiple times, at random.

    EDIT: Experimented to provide more info:

    I think the culprit is Flexible Content, as I’ll lose ACF Field Groups when I add a new Layout & Sub-fields in one of my already existing Flexible Content field types. The field loss/ not saving seems to be at random.

    After updating I would receive message stating that the Field Group was updated, but at the cost of a Field Group. Trying to Add the Field Group again would display the message again, but no field would appear. The only way I was able to get the field back, is by deleting the fields that I had added, then adding the group again.

    I tried downgrading ACF and WP to previous versions, WP_DEBUG isn’t giving up anything.
    I’ve even tried to delete my entire Field Group from my site and start building the layout from scratch. I get to a certain point with no issue, but eventually, I get stuck again…

  • To add to this and maybe help the process of solving the problem… I have noticed that it doesn’t happen for my custom taxonomies (at least it appears to not be happening anyway). From what I have seen, it only happens for fields created for Categories.

    If it starts happening to my custom taxonomies I’ll definitely post an update here.

    And, no replies yet? 2 months later?? Weird, hehe. Here’s hoping a solution is coming in the near future.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.