Home Forums ACF PRO Custom Image Field Not Saving – v5.3.8


Custom Image Field Not Saving – v5.3.8

  • Having problems with latest version – (5.3.8) today.

    This morning I noticed that ACF Pro had updated to the latest version. However I am having problems with adding /updating custom image fields – you can select the image but when you save it either reverts back to the original image if one was already there or if it was blank it does NOT save the selected image!

    I tried this on several sites and the same thing seems to happen! I even tried it on a site that had not updated to the latest version and it worked fine until I updated the plugin and it also stopped working…

    I also tried rolling back to 5.3.7 on one of the sites and this seemed to fix the problem.

    Perhaps it is just me? Please help!

    Thank you for your time on this matter.

  • We’re experiencing the same issue with v5.3.8 on several of our sites. We have a few custom image fields and whenever you try and click on the image button, nothing happens. A few other image fields on the page work fine.

  • I just checked the browser console to see what it was doing and it looks like there are some issues in (acf-input.min.js?ver=5.3.8) on line 1369.

    ReferenceError: Can’t find variable: post_id

  • Ok, I just rolled one of the sites back to v5.3.7 and it resolved the issue. Looks like it’s specific to v5.3.8. Hope all this information helps.

  • Hi Precision Creations – My version of ACF Pro updated automatically to v5.3.8 so before I rolled it back I thought I would try a few things. One of which was to try things in a different browser.

    I have just switched browsers from Chrome to Safari and that strangely seems to have fixed the issue for me. However it was still not working in Chrome, even after I clearer the cookies.So I wiped ALL the browsing data completely and that has fixed the issue for me on Chrome.

    I still want to do some further testing but perhaps you can try that too.

  • Interesting. Ok, thanks for the heads up.

  • It appears, from this conversation, that your browser is not loading the new script that’s needed and that’s causing an error. Chrome is notorious for not loading new scripts and other page dependencies, even when you force a page refresh, it’s just one of the reasons I don’t use chrome for development. Like @Kabrio says, try clearing you browser cache.

  • Hi guys

    Thanks for the bug report and sorry about the issue.

    I believe I have found and fixed the JS error.
    Can you please re-download the latest files and test?

    I’ll release a new update when I have got some feedback


  • Hmm, I just re-downloaded the latest files from the account page and it’s still not working on the site I’m testing. I tested it in Chrome (v50), Safari (v9) and Firefox (v46) on a Mac after I cleared the cache and cookies. All of them give me the same error message in the console.

    ReferenceError: Can’t find variable: post_id

  • My site was affected too.

  • Hi guys,

    Thanks for the replies.

    Can you please add the following to your wp-config.php file:
    define(‘SCRIPT_DEBUG’, true);

    Now try the issue again, and copy paste the full JS error including line number


  • I believe there would be no point in my turning debug on as the wonderful plugin and its scripts appear to be working since I flushed the browser cache(s).

    I also do not see any js errors in the developer’s tool console of Chrome.

    Perhaps it will help to try and force the plugin to download the latest version of the script with a version number change?

    Thanks for the quick response.

  • Ok, I added the debug script to the wp-config and now it works without errors.

    If I remove it and I start getting the same JS error as before. I also tested everything on the default Twenty-Sixteen theme and got the same results.

  • Hello mates,
    Same error but on “Add to Gallery” button on custom content type. It’s strange but on regular page button working without errors. Reverting to previous version works like a charm.

    Enabled js debug showing:

    ReferenceError: Can't find variable: post_id
    /wp-content/plugins/advanced-custom-fields-pro/assets/js/acf-input.js?ver=5.3.8 line 6147
  • HI guys

    Thanks for the replies.

    The issue is only if the field contains the ‘Uploaded to Post’ Library setting.
    This has been fixed and I will release a new update today.

    Please re-download the current plugin files for now (which include the fix) and remember to hard refresh your page to clear out JS caching.

  • Hi @precisioncreations – sounds like your browser has cached the .min JS file.

    Hard refresh your browser, and you should be fine

  • Awesome, thanks for all your work on this @elliot and @hube2!

    Part of the reason I love this plugin so much is you have such incredible support. Keep up the good work!

  • Thanks, Elliot and other contributors!

    I’m waiting for the release.

  • Tested – my issue is fixed! Thank you!

  • Ok, just tested v5.3.8.1 and it works great! Thanks again!

  • Thanks guys. ACF PRO is released an fixes this issue.

  • Hello, I noticed a similar problem with the button on version 5.7.13

  • UPD. Everything is working. The JQUERY was not properly connected in the template.

Viewing 24 posts - 1 through 24 (of 24 total)

The topic ‘Custom Image Field Not Saving – v5.3.8’ is closed to new replies.