Support

Account

Home Forums Backend Issues (wp-admin) "Custom Fields" doesn't appear in dashboard menu

Solved

"Custom Fields" doesn't appear in dashboard menu

  • Hi all,

    I understand that, in my WP-admin dashboard menu, “Custom Fields” should appear below Settings. However, it does not. I tried disabling all of my plugins according to this discussion (http://wordpress.org/support/topic/plugin-advanced-custom-fields-custom-fields-is-missing-in-the-wp-admin-after-upgrade), but the menu item hasn’t appeared.

    Any ideas how I can resolve this?

    Thanks,
    Chris

  • Friendly bump. I haven’t been able to crack this one yet.

  • The custom fields menu item can be hidden. This can be done in several ways and it is done in the code of the site.

    There is the ACF filter, explained here: http://www.advancedcustomfields.com/resources/how-to-hide-acf-menu-from-clients/

    There are also other ways that the menu can be disabled or hidden. This is generally done so that clients do not have access to mess about with things they probably shouldn’t be messing with.

  • Thanks for the quick response, Hube2. Unfortunately, the developers we contracted did not include a function to hide the menu. I did a bit more research along the same lines, and I searched through some CSS to see if anything may have been hidden, but no luck so far.

    I also notice that the checkbox for ACF isn’t included in my Screen Options. I viewed the source, and it’s not hidden, either (it’s just not there).

  • Do a search of your theme template for hooking into the admin menu. Something like:

    
    add_action('admin_menu', 'function_name');
    

    Then look at any functions that are hooked.

    This may be a pain, but you can usually get to the ACF page by entering the URL directly in the location bar:

    
    http://www.yoursite.com/wp-admin/edit.php?post_type=acf
    

    If you can’t access it that way then the permissions needed to access the page have been changed for your user type. Maybe there is a plugin installed that adds controls for who can access what.

  • If I understand this correctly… In acf.php:

    if( is_admin() && !ACF_LITE )
    {
    add_action(‘admin_menu’, array($this,’admin_menu’));

    The function above hooks a function called “admin_menu”, which is further down the file.

    function admin_menu()
    {
    add_utility_page(__(“Custom Fields”,’acf’), __(“Custom Fields”,’acf’), ‘manage_options’, ‘edit.php?post_type=acf’);
    }

    Is this what you’re looking for? Also, I double checked: my account role is Admin.

    Although, the “/edit.php?post_type=acf” trick is just the workaround I need! Hopefully we can get to bottom of the missing menu button problem, though (if not for my sake, then for others’).

    I appreciate all of your help!

  • If you can get to the page by typing in the URL then the developer that built the site has hidden the menu I do this all the time to prevent clients that don’t know what they’re doing from massing about with the field groups I’ve set up.

    Like I said, there are several ways that hiding the menu can be accomplished. One is with code in your theme’s functions.php file.

    Another way is to install an advanced permissions plugin. You may be listed as an admin but you many not have all the permissions of an admin and you wouldn’t be able to see the settings for the permissions plugin to find this out.

    If you really need access to it you should probably contact the developer that built the site and ask them how they’ve hidden it.

  • Thanks again, Hube2! Last I checked with them, they didn’t mention having set up a permissions plugin (as they tried the let’s-disable-some-plugins trick, to no avail). I will reach out to them again, though, and mention this type of plugin. If I hear anything new, I’ll let you know. I’ll also peruse functions.php again.

    Cheers,
    Chris

  • I’m having this issue too, but only on certain servers. I think it might have to do with the path settings, but I’ve been unable to fix it.

    I can access the field groups page from the url, but it is not present in the menu.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.