Support

Account

Home Forums Backend Issues (wp-admin) Custom Fieldgroup Not Showing on User Profile

Solved

Custom Fieldgroup Not Showing on User Profile

  • Hi @elliot,

    This is just a followup to my original message.

    Just for clarity, here’s the basic situation:

    – I have a fieldgroup that applies to all user roles.
    – This appears on the user add/edit page (for users with permission to create new users).
    – For users without permissions to create new users, the fields should appear on the Profile page, but do not.

    CUrrently, location rules are set as:

    User : is equal to : Administrator
    User : is equal to : Representative
    User : is equal to : All

    As I understand it, being logged in as a representative, I should have access to those fields from the Profile page. However, the fieldgroup is not appearing.

    Even logged in as an Administrator, the fieldgroup does not appear on the administrator’s profile page. The fieldgroup is only visible from Users > Add New, or Users > All Users > Username.

    I have also tried using the ‘Logged in usertype’ option.

    Anyway, I’m sorry if I wasn’t clear in my initial question. At this point, I’m just trying to determine if the issue is how I’ve set up the location rules, or if it’s something else.

    Any direction is much appreciated.

    Justin

    ———————————————————-

    justin
    January 9, 2014 at 2:00 am
    Hi @elliot,

    I’m having trouble getting a custom field group to appear on the profile page as well.

    When creating or editing users, the fields appear. However, on the actual Profile page, the fields don’t show.

    So far, I’m using the following location rules:

    User : is equal to : All // (This shows the field group on the Add/Edit User Page)
    Logged In User : is equal to : Representative // (I was thinking that this would show the fields on the profile page for this role, but it doesn’t)

    Anyway, I’m new to the plugin, so any direction about this would be appreciated.

    —————————–

    ACF Guru
    elliot
    January 9, 2014 at 10:14 am
    Hi @justin

    In the future, can you please create a new topic when your question is different to that of the original topic?

    As for your question, the logged in user location rule is exactly that, when the logged in user is ‘Representative’.

    If you want the field group to appear on all ‘Representative’ users, just select the location rule:
    User : is equal to : Representative

    Thanks
    E

  • Hi @justin

    Previously, your location rules had a mixture of ‘User’ and ‘Logged in User’.

    Can you please attach a screenshot of the location rules of your field group so I can confirm what they are?

    Thanks
    E

  • Hey @elliot,

    So, the location rules are currently set as: http://i.imgur.com/5mdWjZ9.png

    But, I’ve also tried stuff like:
    http://i.imgur.com/GFSL54g.png
    http://i.imgur.com/EQuRHEm.png
    http://i.imgur.com/yop6KC6.png

    For all these, logged in as this user: http://i.imgur.com/LXlFzMR.png , the profile is this: http://i.imgur.com/40mqCTf.png

    While creating/editing users as an administrator with the current settings, the fields are visible: http://i.imgur.com/Pmg6KWx.png

    Anyway, I’m not sure what’s missing here. Do you have any ideas?

  • Hi @justin

    Sorry, but I am now quite confused. You say “While creating/editing users as an administrator with the current settings, the fields are visible”.

    Should the field’s be hidden?
    If the location rule says ‘show this field group if user = ‘all”, then this has nothing to do with being an admin or not.

    Perhaps you could clearly describe your end goal and I can direct you to the location rules you need.

    Thanks
    E

  • Hey @elliot,

    My goal is to display this fieldgroup on the user profile page.

    Justin

  • Hi @justin

    In a previous comment, and the text I quoted, you said ‘the fields are visible’.
    So the fields are displaying on the user profile page.

    I don’t see what the issue is…

  • Hi @elliot:

    The problem is that if a representative logs in, they cannot see this field group.

    It is only visible to Administrators from the Add/Edit User screen.

    This fieldgroup should visible and editable for a representative when they visit their own profile.

  • Hi @justin

    Can you please check your console log for any JS errors on the profile edit page. Any JS error will prevent ACF from loading on this page.

    Thanks
    E

  • Hey @elliot,

    There are no js errors on the user profile page.

    Justin

  • Hi @justin

    Can you please create me an account and provide login details for me to see the issue?

    Please test logging in with this account to double check I can see the issue and also include a step by step guide to seeing the issue.

    I’ll need access to the field group edit screen and the user edit page in question.

    Thanks
    E

  • This reply has been marked as private.
  • Hi @justin

    Thnaks for the login.

    I can see that another plugin is modifying the DOM which is preventing ACF from finding the normal p.submit element.

    I have made a change to the JS selector to allow for these kinds of situations and will release this in the next version.

    I have also modified your ACF plugin to include this fix.

    Thanks
    E

  • Hi @elliot:
    I’ve encountered a similar problem and have done some digging to try and get to the bottom of it. I tried the fix you mentioned above (got the new code from github: https://github.com/elliotcondon/acf/commit/df4386fa71f8392aaa6b1ac4aff3e3974b68a782) and it didn’t work.

    When the user type “subscriber” is logged in, they can see the custom fields that are assigned to “User = All”.

    However, both a “contributor” and an “author” cannot see these fields. The next step up, “Editor” and, of course, “Admin” can.

    I messed around with the capabilities assigned to the various roles. And when I add “edit_posts” as a capability to “subscriber” it breaks. I haven’t figured out what other capabilities “counter balance” the issue to where an Editor is able to see the custom fields in their profile.

    I even edited “everything_fields.php” to try and see if moving the placement of the custom fields helps. I changed line 424 to echo "$('#createuser > table.form-table:first > tbody').append( html );";. The same issue manifested.

    Thought that this may help to further address the issue. Of course I’m trying to achieve every user type to see the custom fields assigned to the post type = user.

    Deep thanks for the hard work on this family of plugins. I use almost all of them now on a daily basis. They rock!

    -Nic

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.