Home Forums Backend Issues (wp-admin) Custom field doens't show for specific user


Custom field doens't show for specific user

  • Hello guys,

    I have just one custom field and it seems to be ok for me, but for my writer (other user) it doesn’t show. I’ve changed the role to admin and I tried to see if it shows to another users, and it shows. It doesn’t just only for this specific user.

    What can I do to solve this?

  • Is it just one field or the entire field group? Does the field group appear and the field is missing from it or is the field group not showing?

  • I just have one field on the field group, so it doesnt show anything for the user :/

  • There seems to be some confusion between a “field group” and a “field”. A field group contains 1 or more fields. A field is one item in a group.

    A field group will be shown even if it contains no fields.

    From your response I am going to assume that you mean the field group is not being shown. If this is the case then the first thing I’d check is the “Screen Options” (tab at the top right of the edit screen) and make sure that the check box for the group is ticked.

  • Well, the entire field grou is not being shown only for one user.

    I made this video for you:

  • At this point I’m stumped. I would start with basic debugging stuff, deactivating other plugins, trying a different theme, etc, to see if I could narrow down the problem. All I can think of is that there is a filter somewhere causing the issue, but why it would only affect one user? No clue.

  • I’ve tried all, desactivated all the plugins and changed the theme but didn’t worked. It only happens with this user, I tried to create new user and worked, but I want to know what is causing the issue with this specific user.

  • Have you used any type of a role or permission editor on the site? Sometimes these types of plugins make changes in the database that are not reset if the plugin is deactivated.

  • No, and the other user is admin too

  • Having the same issue. I’ve checked multiple users on our site. All but one user displays the field groups as expected. The user profile that doesn’t display them is an administrator, as are other users I’ve checked that worked successfully.

  • I am facing the same issue, there are multiple field groups are there but one group is not showing for a user. the user is the administrator and it works fine for all other administrators. I have checked the screen option all groups are checked.

  • I had a similar issue. In the end a coworker had the idea of comparing the user meta for the affected user and a new user where it worked.
    I could then solve it by deleting two entries in the wp_usermeta for that user (Keys: “meta-box-order_page”, “meta-box-order_post”).

    I think in my case this was somehow messed up during the update from Classic Editor to Gutenberg Editor.

  • Super strange but @hhenning’s suggestion helped lead me in the right direction, too.

    I removed those entries “meta-box-order_page” and “meta-box-order_post” but did not have success. I also found an entry called “metaboxhidden” and in the meta_value is clearly had an ACF field group key. Once I removed that the ACF fields appeared for that user.

    Thanks @hhenning

  • @rcneil’s comment brings up something extremely simply that we all overlooked. The user hid the field group under screen options… you know that expandable box at the top of the screen that everyone overlooks? Even me….

  • John Huebner’s comment led me to the “fix”. Thank you, John!

    I was worried there was something a lot more serious going on. Luckily it’s just an option the user must have unchecked.

  • I just encountered this with a client, and though the Screen Options was my first thought, I’d not run into this before since switching to Gutenberg. Screen Options were so easily accessible in Classic, now they’re fully buried. For anyone searching, they’re located here: Top Righthand Hidden Menu (three vertical dots) -> Preferences (at the very bottom of the menu) -> Panels tab (lefthand tab in the popup) -> “Additional” section.

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Custom field doens't show for specific user’ is closed to new replies.