Home Forums Backend Issues (wp-admin) Cropping Post Images result to NaN Error


Cropping Post Images result to NaN Error

  • When cropping images for a post, I get a NaN value under the Selection

    This happens to the newest wordpress version: 4.6.1. I have tested it on a blank wordpress install with just the ACF plugin installed.

    How to replicate:
    – Add image to a post (which has ACF)
    – Click Edit Image
    – Make the Crop
    – NaN appears under selection and it will not crop

    This does not happen if i am cropping images from the media library. This only happens to posts and pages.

  • Hi @mikeictinus

    I’m afraid I can’t reproduce this issue on my end. Could you please tell me the browser you were using and its version? Could you please tell me the version of your ACF?

    Also, could you please check the developer tools of your browser to see any error messages on the page?

    Thanks 🙂

  • Hello James

    Thank you for looking at my problem.

    Here is what I have done:
    – I have installed a new empty wordpress installation on my local machine using mamp. (Mac El Capitan, Mamp 3.5)
    – I installed the Advanced Custom Fields plugin Version 4.4.8 only (no other plugins are installed)
    – I create a custom image field for a post
    – I go to the “Hello World” post, add an image and the click “Edit Image” from the post.
    – I get a NaN selection

    Here is a screenshot

    I have tried it on many installations and on several computers. No javascript errors whatsoever. I don’t know what is going on.


  • Same thing happened to me.

  • Hi @mikeictinus and @intheattic

    I think this issue is related to WordPress. If I disabled ACF and refreshed the image edit page, the issue persists. So it means the issue is not related to ACF.

    Could you please get in touch with WordPress support?

    I hope this makes sense 🙂

  • If I disabled ACF and refreshed the image edit page, the issue persists.

    Hello James

    I have tried the same thing but the issue does not persist for me. I am positive that it is related to acf. The NaN error happens only when the advanced custom fields plugin is installed. It seems that the default WordPress edit crop is working fine.

    If you remove the &image-editor at the end of the url, the NaN error is gone. Can you take a further look at this please?

    Thank you

  • Hi @mikeictinus

    It seems there’s a different behavior between the free and the PRO version. When you click the Edit Image link, it shouldn’t redirect you to a new page, but shows the editor in the image selection modal box. Could you please open a new ticket so this issue can be passed directly to the plugin author? You can open a new ticket here: Also, please don’t forget to explain the issue again and provide the link to this thread.

    Thanks 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Cropping Post Images result to NaN Error’ is closed to new replies.