Home Forums General Issues Content missing after update from 2.0.5. to 4.3.4.


Content missing after update from 2.0.5. to 4.3.4.

  • Hello,

    I’m having a huge problem after upgrading from a very old ACF Version (2.0.5) to 4.3.4.

    Instead of seeing the content assigned to the custom fields I just see some IDs (like 4365 etc.) Some custom fields have a 0, even if I assigned some content to them.

    I tried to go back to the old version, but the problem is still there. Strangely even after reverting the database. I also tried to make a step by step upgrade, that means upgrading first from 2.0.5. to 2.1.1. then to 3.0.0. then to 3.0.4. etc – nothing helped!

    Is there any solution to this? Please help me, my client is going to kill me!!

    Thanks in advance, Karina

  • Hi @cgoldt

    For upgrading from v2, I would suggest the upgrade path you have posted:
    Upgrade to last v2, then first v3, then last v3, then first v4, then last v4.

    Make sure to run any Database upgrade messages which appear upon activation of the plugin.


  • Hi elliot,

    how I said, I tried this. But it didn’t help.
    Now I don’t even care anymore which version of ACF is running, I just want the website running again.

    How can I fix it? Everything is broken!

  • Hi @cgoldt

    The easiest solution is to restore your website to a backup.

    Perhaps attempt to run the ACF updates on a local installation to avoid breaking your live website.


  • Hi Elliot,

    An old client has reached out to me after foolishly upgrading not only their WordPress install to the latest version (4.1), but also the previous version of ACF (3.?) to 4.4.0. without any regard to compatibility in general. Obviously some things have broken, and I’m trying to determine the quickest way to restore things to a working version. Of course there are no site backups, and from what I can tell, it appears that the previous custom fields I created are missing (not displaying), BUT the field groups themselves ARE still in tact. I’ve read in the forums about database upgrades during the plugin upgrade process and was wondering if that was something I could force to occur as a possible quick solution? As I’m exploring options, I was also wondering if you could provide me with information to download previous versions (3.x etc) to try resolving that way. For whatever reason, I’m unable to find those links on your site.

    Many many thanks in advance!

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Content missing after update from 2.0.5. to 4.3.4.’ is closed to new replies.