Support

Account

Home Forums ACF PRO Can't use conditional fields after last update.

Solved

Can't use conditional fields after last update.

  • I can’t use conditional field logic after the most recent ACF Pro update. Is anyone else having this issue? When I select the ‘yes’ radio button no options appear anymore. Conditional field logic was working fine up until the update.

  • I can confirm this bug has arisen since the last update. Sad face.

  • I can confirm this issue as well.

  • Can confirm this issue as well.

    • pauldo

    • July 18, 2014 at 4:03 am

    I am having this issue as well.

  • Confirming again due to different forum.

    • User10

    • July 18, 2014 at 8:42 am

    Experiencing the same issue, really need this working.

  • Yep – same here. Is there any way of knowing that Elliot / Someone Else is working to fix this?

    • kdsign

    • July 21, 2014 at 11:19 pm

    Here too.

    • ajoen

    • July 21, 2014 at 11:28 pm

    I have a workaround for this. Check it here: Taxonomy Term – “Show this field group if” not applying

    Hope this helps.

  • Thanks ajoen – although what you’re experiencing is slightly different. The conditional logic you’re dealing with is to do with what objects a group of custom fields is attached to. I believe what we’re dealing with is conditional display of fields – i.e. if Field X has value of Y, show Field Z. 🙂

    • Elliot

    • July 22, 2014 at 10:01 am

    Hi guys.

    Thanks for the bug report and sorry for the issue. This has been fixed and an update will be out shortly.

  • Awsesome, Thanks!

  • Hello

    In my application, I am using a custom field of type radio and putting the values ​​as follows: (red: <img src='http://www.site.com/red.gif' />) thus my user can choose an image and not text, easing administration. This works OK.

    The problem is that I want other fields are conditional on this. When I select another field is conditional and select this radio, the options do not appear, this because the ACF seeks the legend and not the value of the radio.

    Example:

    Type: Radio; 
    Name: color; 
    Values ​​(
    red: <img src='http://www.site.com/red.gif' /> 
    green: <img src='http://www.site.com/green.gif' /> 
    blue: <img src='http://www.site.com/blue.gif' /> 
    ) 
    Type: Text; 
    Name: Title-Box; 
    Conditional: (
    When color == green 
    ) 

    I believe that the whole problem is to be using an html image where it should be text only. However I think the plugin should fetch the value of the radio and not the label.

    • pauldo

    • July 23, 2014 at 2:08 am

    Thank You Elliot!

  • Yes, Thank You Elliot, being new to ACF I sure am stoked how quickly you have responded to this issue!

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.