Support

Account

Home Forums Add-ons Repeater Field Can't save subfield definitions

Solved

Can't save subfield definitions

    • edank

    • January 5, 2019 at 6:42 am

    Hi,
    When I define a repeater or a group with subfields, when I publish or update the page, the subfields get ‘pulled out’ of the repeater/group and the page saves the desired subfields as a regular field alongside the repeater/group.

    I’m working on a new WP instance, currently locally, and this is the 3rd site i’ve used ACF on, and this has never happened to me before.

  • I’ve had this happen on a site in the past, and I don’t know what caused it. In my case I was using a flex field. I copied a field in one layout and then moved it to another layout, after saving the field group the field had moved itself back to the original layout. I believe this was being caused by the parent not being set correctly when moving the field. I never tracked down the cause. I corrected the situation by only creating fields directly in each layout. Added some work, but I needed to get the project done. There was probably something going screwy in the JS for this site.

    A repeater could cause the same issue. If you create a field at the top level and then move it into the repeater, if the parent is not set correctly before saving then the field would likely move back to the top level?

    On the other hand, if you created the field in the repeater…. well, I don’t know, unless there is something wrong with the parent setting when the field group is submitted for update. It could be that some other script running on the page is interfering with this.

    • wroxbox

    • January 8, 2019 at 11:44 pm

    The same is happening with us. ACF Pro version 5.6.8 and wp 5.0.2

    Tried to use Group type with subfields (text and relation)

    https://www.dropbox.com/s/piaet08p5g8r6ej/screencast%202019-01-08%2014-48-47.mp4?dl=0

  • There is a new version of ACF available, it’s now up to 5.7.9.

    Can you update and let me know if this is still happening?

    • wroxbox

    • January 9, 2019 at 1:25 am

    Oh. Old codebase. Updated. Resolved my issue. Thanks!

    • edank

    • January 12, 2019 at 8:10 am

    It worked after the update. Thanks.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.