Support

Account

Home Forums Backend Issues (wp-admin) Can\'t edit user submitted custom post

Solved

Can\'t edit user submitted custom post

  • Hi community,

    I am having an issue where I cant edit another user’s custom post submission.
    When I got to the WordPress Editor signed in as the admin I can edit my own posts…but when I click on someone else’s post the Update button is dimmed. See the screenshot below:

    https://www.dropbox.com/s/b3tk74lktacjkoi/Screenshot%202019-10-17%2012.38.26.png?dl=0

    I used a typical ACF Form with the code below to hand post submission if thats helpful.

    <?php
    $args = array(
        // Whether the title should be displayed or not (true/false)
        'display_title' => false,
        
        // Whether the description should be displayed or not (true/false)
        'display_description' => false,
        
        // Text used for the submit button
        'submit_text' => 'Submit',
        
        // The URL to which the form points. Defaults to the current URL which will redirect and automatically display a success message after submission
        // If this is overriden you may use af_has_submission to check for a form submission
        // 'target' => CURRENT_URL,
        
        // Whether the form output should be echoed or returned
        'echo' => true,
        
        // Field values to pre-fill. Should be an array with format: $field_name_or_key => $field_prefill_value
        'values' => array(),
        
        // Array of field keys or names to exclude from form rendering
        'exclude_fields' => array(),
        
        // Either 'wp' or 'basic'. Whether to use the WordPress media uploader or a regular file input for file/image fields.
        'uploader' => 'basic',
        
        // // The URL to redirect to after a successful submission. Defaults to the current URL which will display a success message after submission.
        // 'redirect' => CURRENT_URL,
        //
        // // ID to use for form element. Defaults to form key.
        // 'id' => FORM_KEY,
        
        // Filter mode disables the success message after submission and instead displays all fields again with their submitted values.
        'filter_mode' => false,
        
        // 'label' to place instructions right below label or 'field' to place them after the field.
        'instruction_placement' => 'label',
        
        // Add a honeypot to prevent spam submissions. Enabled by default.
        'honeypot' => true
    );
    
    advanced_form('form_XXXXXXXXXXX', $args);
    
    ?>

    Any help is greatly appreciated.

    Adam

  • I solved my own problem. Basically my Title was empty so WP wasnt allowing it to even show the option of saving. You must-have title in order to save so adding that in changed the state and allowed me to start Updating posts again.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.