Home Forums Add-ons Gallery Field can't edit images in Gallery field


can't edit images in Gallery field

  • Hi there – I’ve implemented a Gallery field on a site, and so far everything has been great, except that today I discovered that only two of the four admin users can edit images once they’re uploaded to the field.

    For the two that cannot edit images, if you click the pencil icon, the popup opens and it says “Edit Image” but then the media uploader is the only option. No title/caption fields, etc. (screenshot attached)

    I should note that ALL admin users can drag-and-drop the image order, so that function is still intact. Also, I added a brand new admin and this new user cannot edit images either. Plus I’ve done the standard “disable all other plugins and switch to default theme” testing and nothing changes it so far.

    Is there a setting I’m missing that limits admin users ability to edit? What could be causing this? It’s strange that two admins have the function and two do not.

  • Ok one more thing about this – the new admin user that I just now added did not have the ability to edit images until AFTER that user had added an image to a gallery. Somehow adding an image allowed the user access to edit ALL images. So I’m not sure what’s going on. Bug? Or intentional?

  • Hi @panmac

    This sounds like a bug for sure. I’ll add it to the to-do and see what I can find.


  • Hi all,
    Just wanted to chime-in that this is also happening to me. Oddly enough admins seem to be okay, but Editors were able to edit at one point and then it stopped, not sure what’s going on. Thanks!

  • Having this problem as well. Gallery field 1.1.0, WP 3.8. Two of my admin users can edit captions / titles on images, but my editors can’t. Tried upgrading the editor to be an admin, but still only shows “Drag files here to upload.” Even tried creating a new admin account entirely but it has the same issue.

  • Noticed that any “new” users, no matter what they’re level are able to edit captions. Gallery field 1.1.0 and WP 3.8.

  • To add to my original messages – this is still an issue, and happens intermittently regardless of user role. I have several admins who will be able to edit images, but then suddenly can’t, unless they upload a new image. And it doesn’t even matter if the image upload is successful – the upload can stall out, and for whatever reason, once they’ve tried that, then editing capabilities are restored.

    I’m trying to recreate this bug on demand, but can’t forcibly do anything to make it happen – it’s simply, suddenly, editing capability disappears altogether.

    Unfortunately it’s making me look like a jerk because the client is trying to load their content (and, of course, the site is for a photography agency, so this function is key). I just keep saying “I’m working on a fix”…

    Eliot – any further ideas? Or any other info I can provide to help you out?

  • Hi @panmac

    Thanks for the follow up. I will be looking into this soon. Currently, this issue has had to be placed back in queue behind some other high priority items.

    If you are able to debug some JS, that would be great. Start with the gallery field JS, then move into the ACF input.js file.


  • Overall, I love this plugin and ACF in general is awesome, so first off, thanks for creating it! I am having the same issue as described above with the gallery for two of my clients. Any fixes on the horizon?

    Many Thanks,


  • Hi guys.

    I have a feeling that this issue is caused when the last viewed ‘state’ is the ‘upload’ tab.

    I have fixed this issue and will soon release an update, however, can you please test his by editing the gallery field’s js/input.js file and adding on line 181:

    // set to browse
    if( _media.frame.content._mode != 'browse' )


  • That seems to have fixed it. Thanks!

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘can't edit images in Gallery field’ is closed to new replies.