Support

Account

Home Forums Backend Issues (wp-admin) Can't edit a page which uses a repeater field

Solved

Can't edit a page which uses a repeater field

  • When I try to edit a page which is using the repeater field for a timeline slider I’m getting an Internal Server Error. I tried updating core files, updating plugins, WP and so on – didn’t do it.
    But when I remove the ACF group ( the repeater field consists of a radio button, a date picker and a few text fields ) from the page everything is working fine and I can open the editor again. I have a lot of fields and maybe that’s where the error is coming from. Also after looking in the db I found that for one title for e.g. I have six same rows. ( I don’t know if this is normal )
    Any help or ideas would be appreciated.

  • Hi @dineva

    This is a bit odd, I don’t think the issue is stemming from the number of fields.

    Have you been able to replicate this issue when all other plugins have been deactivated and while running one of the stock WP themes?

  • Hi @james
    I deactivated all plugins except for ACF – still can’t edit the page. Also switched the theme – still nothing. After deactivating ACF I can edit the page again.

  • I am having the same issue. The page throws this –

    input.js?ver=1.1.1:52 Uncaught TypeError: this.$values.unbind(...).sortable is not a function(…)

    for –

    
    			// sortable
    			if( this.o.max != 1 )
    			{
    				this.$values.unbind('sortable').sortable({
    					items					: '> .layout',
    					handle					: '> .acf-fc-layout-handle',
  • It seems like I’m experiencing the same error as well. I’m not getting any javascript errors; when I update a wordpress page, it simply does not save the edits I made to a group of fields if one of them is a repeater field.

  • Hi @dineva

    Could you please share the JSON export file of your field group so I can test it out on my installation? Also, could you please check your error log on your server? The error log usually shows more detailed information about the issue.

    @jlundie

    Have you tried to reproduce the issue on one of the WordPress’ stock themes (like Twenty Fifteen) with only ACF activated? Sometimes, WordPress plugins and themes are not coded correctly, and it can cause a conflict between each other. By deactivating them, we will know right away if there’s a conflict on your site or not. If we know which one caused the issue, we can focus on that theme/plugin alone to solve it.

    @sprout

    It’s possible that you have the max_vars variable issue. Could you please try the solution on this page: https://www.advancedcustomfields.com/resources/limit-number-fields/?

    Thanks 🙂

  • Hi @james,
    Here is the error log records from the server:

    [Wed Nov 16 08:16:50 2016] [warn] [client 00.000.000.00] mod_fcgid: stderr: PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, first array member is not a valid class name or object in /var/www/vhosts/mywebsite.com/wp-includes/plugin.php on line 235, referer: http://mywebsite.com/wp-admin/
    [Wed Nov 16 08:18:08 2016] [warn] [client 00.000.000.00] mod_fcgid: read data timeout in 45 seconds, referer: http://mywebsite.com/wp-admin/edit.php?post_type=page
    [Wed Nov 16 08:18:08 2016] [error] [client 00.000.000.00] Premature end of script headers: post.php, referer: http://mywebsite.com/wp-admin/edit.php?post_type=page

    No other errors are shown in the console.

  • Hi @james

    Here is the json export of the field group

  • Hi @dineva

    The issue seems related to your server settings. First, could you please increase the max_vars variable as mentioned on this page: https://www.advancedcustomfields.com/resources/limit-number-fields/?

    Second, from the error log you gave me, it seems related to mod_fcgid. To fix it, please check this thread: http://stackoverflow.com/questions/14488567/premature-end-of-script-headers-index-php-mod-fcgid-read-data-timeout-in-61-s. If you don’t know how to do it, kindly get in touch with your hosting provider instead.

    Thanks 🙂

  • Thanks for your fast response! Sorry for the delay – I can’t actually swap themes on my client’s site while it’s live and had to get the site migrated to a dev server for troubleshooting. But that gave me more info. When I migrated the site to my development server (Bluehost), I get no error, even with all other plugins activated on our theme.

    When I check the console log for load, the error listed in my initial post does not exist on Bluehost. It still exists on the client site (Rackspace).

    At this point, this definitely seems like it’s not an ACF issue (or if it is, it’s a collateral damage in ACF v. Rackspace settings conflict). Do you have any suggestions?

    Thank you!

  • Hi @jlundie

    It’s possible that you have a caching issue on your live site. Could you please try to clear the cache and disable the caching feature provided by Rackspace?

    If the issue persists, could you please get in touch with their support?

    Thanks 🙂

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.