Home Forums Bug Reports Can't delete rows in Repeater + conditional error


Can't delete rows in Repeater + conditional error

  • Hi,

    I’ve found two bugs in the Repeater Add-in

    1. I can’t delete rows… The ‘-‘ buttons are missing…
    2. The fourth column has a conditional statement. The text area in this column should show up when the checkbox in column two is checked. Sometimes it works. Other times not.
  • Hi @Exelmans Graphics

    Thanks for the screenshots and xml file.
    I’ll import and do some testing.


  • Hi Elliot,

    I don’t want to be impolite, but do you have an idea how much time it’s going to take to fix this issue? I kinda need this in a live website where my client’s waiting to input content.

    thanks in advance,


  • Hi @Exelmans Graphics

    I’ve just imported the field group and done some basic testing.
    The repeater field is working great for me, so perhaps your issue could be due to an older version of ACF / repeater.

    What versions of ACF / repeater are you using?

    Have you tried updating ACF to the latest code on github? Does this fix the issue?


  • I’m using ACF 4.3.4. and Repeater 1.1.1. I’ll try the latest build on GitHub.

    Edit: tried the GitHub version. Everything’s fine for now. Thanks!

  • Hello I am using ACF 4.3.9 and Repeater 1.1.1, and am experiencing this same issue. Once we create a row of a repeater field, it cannot be deleted. Once we update the post, its back in place again.

    Looks like version 4.3.8 is in the repo, so I’m not sure if it makes sense to use that version, as the previous comments recomment.

    We have created a workaround in our PHP, so its not an emergency. But it is a bit confusing and disconcerting for our clients, when we have to explain not to worry about the un-removable row.

    Andrew Croce

  • Hello, I wanted to follow up again on this issue, since it is still occurring for me. To reiterate, I have a repeater with no minimum rows set, and I cannot delete the last/only row. After saving the post when the row has been removed in the UI (-) it is not deleted and leaves an empty row.

    I am using the latest version of ACF and Repeater, 4.4.2, and 1.1.1.

    Attached its the XML export of our field group.


Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Can't delete rows in Repeater + conditional error’ is closed to new replies.