Support

Account

Home Forums ACF PRO Can't create new fields in ACF5

Solved

Can't create new fields in ACF5

  • Hi,

    After updating to ACF v5 I can’t create new fields on an existing install.
    On the Edit Field Group page I add a new field then click update and I get an alert saying “are you sure you want to leave this page.” A spinner icon spins for the update button, but never finishes.

  • Hi,

    I’ve encountered this issue to. I can’t change Field Groups at all. When I press Update I get the same message as nicgranleese. It just keeps on spinning.

  • Same happened here. However, if you choose to leave the page the group will be saved. Hope it can be fixed.

  • For me it wasn’t saved. Tried several times and with different browser.

  • Update on this issue.
    I installed Version 5.0.7 update of ACF Pro.
    It removes the alert pop up, but the save process still has a bug.
    It saves the new field as a field group.

  • Hi guys

    Sorry about the popup issue. This has been fixed in v5.0.7 – please update.

    @nicgranleese – are you able to provide a login account for support@advancedcustomfields.com? Please also enable DEBUG_MODE in your wp-config.php file and I’ll do some testing

  • Hi Elliot,

    Thanks for the update.
    Let me deactivate all the plugins on the site and see if I can find the bug.
    If I still can’t find the problem I’ll definitely take you up on the debugging offer.
    Thanks.

  • Ok, found the plugin conflicting with ACF 5 is Post Type Switcher. https://wordpress.org/plugins/post-type-switcher/
    Deactivated it and all is good again.

  • Sorry to bother. But I deactivated every plugin except ACF Pro (latest version 5.0.7) and Custom Post Type UI and Chrome keeps prompting me:

    The changes you made will be lost if you navigate away from this page
    Are you sure you want to leave this page?

    Even if I hadn’t make any changes to that post.

    Thank you again!

  • Hi @40q

    Can you please perform a hard refresh to make sure the new JS is loaded

  • Elliot, thanks for the answer, but it keeps prompting me to save before leaving, even if I hadn’t edited anything. I tried with this hard refresh you suggest.

    When I deactivate the plugin everything works fine. Sorry I can not be more specific. I’m also trying to figure it our why this is happening.

    Thanks anyway.

    Cheers!

  • Hi @40q

    Thanks mate. Any chance you cans setup a login account for me to test?

    Thanks
    E

  • Hi all,

    When I was debugging the other day I checked Custom Post Type UI plugin, but didn’t have any issue with it. I’ve still got it activated now and without issue.

    Nic

  • This reply has been marked as private.
  • Hi @40q

    Thanks for the login, I just added a new field to the last field group in the list, and it worked fine.

    No prompt to leave the page, and the test field exists

  • Elliot, thanks for your concerns. Where this is happening is when I try to add or edit a post type (in this case, “propiedades”). Even without changing anything I receive this alert. That stops happening if i deactivate acf plugin.

    Thanks anyway!! I’ll try to find a solution!!

  • Hi @40q

    Thanks for the clarification. It looks like something on the page is triggering a ‘change’ event which is then causing ACF to prompt.

    I’ll try to replicate the issue locally and find a fix

  • Hi @40q

    I’m having a hard time replicating this locally. Do you have any scripts which are changing or triggering a change on an ACF input?

  • This reply has been marked as private.
Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.