Home Forums Backend Issues (wp-admin) Can't click visual tab since latest update


Can't click visual tab since latest update

  • My visual tab in the wp admin panel no longer works. On page load I see this JS error:

    Uncaught ReferenceError: instanceId is not defined
        at Object.build_quicktags (acf-input.min.js?ver=5.6.2:3)
        at Object.initialize_quicktags (acf-input.min.js?ver=5.6.2:3)
        at Object.initialize (acf-input.min.js?ver=5.6.2:3)
        at Object.initialize (acf-input.min.js?ver=5.6.2:3)
        at acf-input.min.js?ver=5.6.2:1
        at d (acf-input.min.js?ver=5.6.2:1)
        at Object.i (acf-input.min.js?ver=5.6.2:1)
        at Object.do_action (acf-input.min.js?ver=5.6.2:1)
        at Object._load_field (acf-input.min.js?ver=5.6.2:1)
        at d (acf-input.min.js?ver=5.6.2:1)

    When clicking the visual tab nothing happens and I get this error:

    Uncaught TypeError: Cannot read property 'onpageload' of undefined
        at h (wp-tinymce.php?c=1&ver=4603-20170530:15)
        at m (wp-tinymce.php?c=1&ver=4603-20170530:15)
        at h.l.bind (wp-tinymce.php?c=1&ver=4603-20170530:3)
        at o.bind (wp-tinymce.php?c=1&ver=4603-20170530:5)
        at Object.init (wp-tinymce.php?c=1&ver=4603-20170530:15)
        at e (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,wp-pointer,heartbeat,autosave,wp-ajax-response,jquery-color,wp-lists,jquery-query,admin-comments,su&load[]=ggest,postbox,jquery-ui-menu,jquery-ui-autocomplete,tags-suggest,tags-box,word-count,post,editor-expand,thickbox,shortcode,backb&load[]=one,wp-util,wp-backbone,media-models,wp-plupload,mediaelement,wp-mediaelement,media-views,media-editor,media-audiovideo,mce-view&load[]=,imgareaselect,image-edit,svg-painter,wp-auth-check,jquery-ui-slider,jquery-touch-punch,iris,wp-color-picker,wpdialogs,editor,me&load[]=dia-upload,wp-embed&ver=8f742da85714034430150ece160aacbf:709)
        at HTMLDocument.<anonymous> (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,wp-pointer,heartbeat,autosave,wp-ajax-response,jquery-color,wp-lists,jquery-query,admin-comments,su&load[]=ggest,postbox,jquery-ui-menu,jquery-ui-autocomplete,tags-suggest,tags-box,word-count,post,editor-expand,thickbox,shortcode,backb&load[]=one,wp-util,wp-backbone,media-models,wp-plupload,mediaelement,wp-mediaelement,media-views,media-editor,media-audiovideo,mce-view&load[]=,imgareaselect,image-edit,svg-painter,wp-auth-check,jquery-ui-slider,jquery-touch-punch,iris,wp-color-picker,wpdialogs,editor,me&load[]=dia-upload,wp-embed&ver=8f742da85714034430150ece160aacbf:709)
        at a (wp-tinymce.php?c=1&ver=4603-20170530:3)
        at HTMLDocument.p (wp-tinymce.php?c=1&ver=4603-20170530:3)

    Note, Wp-Types is also being used on this site.

  • Same issue here. I have multiple WYSIWYG editors on a custom post type. The first visual editor loads fine, however, the remaining editors do not load. Instead, Chrome console gives me the following error:

    Uncaught TypeError: Cannot read property 'onpageload' of undefined
        at h (tinymce.min.js?ver=4603-20170530:14)
        at m (tinymce.min.js?ver=4603-20170530:14)
        at h.l.bind (tinymce.min.js?ver=4603-20170530:2)
        at o.bind (tinymce.min.js?ver=4603-20170530:4)
        at Object.init (tinymce.min.js?ver=4603-20170530:14)
        at e (editor.min.js?ver=65c0a7335dc6663744f226e2b48b91ca:1)
        at HTMLDocument.<anonymous> (editor.min.js?ver=65c0a7335dc6663744f226e2b48b91ca:1)
        at a (tinymce.min.js?ver=4603-20170530:2)
        at HTMLDocument.p (tinymce.min.js?ver=4603-20170530:2)

    I have tried deactivating all plugins. Will try downgrading my version of ACF.

  • Hi,

    Following up on my last post. Downgrading to version 5.6 fixes the problem for me. All visual editor tabs are working perfectly fine now.

  • Hi @tanvi I was thinking about doing that as well but would like to avoid downgrading, was hoping the ACF team might be able to chime in and let us know if this will be fixed soon.

  • This has been reported in other topics and I’ve tested it and cannot recreate the issues being seen by some people. More than likely this is happening due to a conflict with another plugin or something in the theme. In order to figure out what’s going on the first thing that you need to do is figure out where that conflict is. You can do this by deactivating plugins to see if you can clear up the problem and if that fails to try switching themes.

  • @hube2 I believe its related to a conflict with wp-types.

  • For me this occurs when Toolset Types is activated. Is there a way to prevent this conflict?

    I’m working with another developer on my project and so it may not be possible to deactivate Toolset Types (and TT can’t do repeater fields like ACFR can!)

  • Hi folks,

    I’ve come across the same issue. Did you get anywhere? Is it Toolset or ACF that’s at fault here? Is there a workaround?


  • My workaround was to disable the WYSIWYG editor.

  • Rolling back to 5.6.0 and the problem goes away…

  • I was having the same issue when trying to drag a widget containing a wysiwyg field onto a sidebar. Some testing proved that it was the presence of the Visual tab in the wysiwyg editor. If I changed it to show only the Text tab, the error went away. But I opted to downgrade ACF instead. 5.6.1 works for me, but 5.6.2 and 5.6.3 both generate the “Uncaught TypeError: Cannot read property ‘onpageload’ of undefined” error.

  • For anyone having a problem with this I would submit a new support ticket here

  • Is there any way to debug these specifically? I am having a similar issue on my live site, cant reproduce it on my local site. Presumably an offending plugin should be something that uses tiny-mce i.e. has a WYSIWYG editor on the edit page?

    My error code:

    tinymce.min.js?ver=4607-20180123:14 Uncaught TypeError: Cannot read property 'onpageload' of undefined
        at e (tinymce.min.js?ver=4607-20180123:14)
        at k (tinymce.min.js?ver=4607-20180123:14)
        at h.l.bind (tinymce.min.js?ver=4607-20180123:1)
        at o.bind (tinymce.min.js?ver=4607-20180123:3)
        at Object.init (tinymce.min.js?ver=4607-20180123:14)
        at e (load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,thickbox,jquery-ui-tabs,wp-mediaelement,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp&load[]=-lists,postbox,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box,underscore,word-count,post,editor-expand,shor&load[]=tcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-api-request,media-views,media-editor,media-audiovideo,mce-view,im&load[]=gareaselect,image-edit,svg-painter,wp-auth-check,media-upload,jquery-ui-button,editor,quicktags,wplink,wp-embed&ver=4.9.4:670)
        at HTMLDocument.<anonymous> (load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,thickbox,jquery-ui-tabs,wp-mediaelement,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp&load[]=-lists,postbox,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box,underscore,word-count,post,editor-expand,shor&load[]=tcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-api-request,media-views,media-editor,media-audiovideo,mce-view,im&load[]=gareaselect,image-edit,svg-painter,wp-auth-check,media-upload,jquery-ui-button,editor,quicktags,wplink,wp-embed&ver=4.9.4:670)
        at a (tinymce.min.js?ver=4607-20180123:1)
        at HTMLDocument.p (tinymce.min.js?ver=4607-20180123:1)
    e @ tinymce.min.js?ver=4607-20180123:14
    k @ tinymce.min.js?ver=4607-20180123:14
    l.bind @ tinymce.min.js?ver=4607-20180123:1
    bind @ tinymce.min.js?ver=4607-20180123:3
    init @ tinymce.min.js?ver=4607-20180123:14
    e @ load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,thickbox,jquery-ui-tabs,wp-mediaelement,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp&load[]=-lists,postbox,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box,underscore,word-count,post,editor-expand,shor&load[]=tcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-api-request,media-views,media-editor,media-audiovideo,mce-view,im&load[]=gareaselect,image-edit,svg-painter,wp-auth-check,media-upload,jquery-ui-button,editor,quicktags,wplink,wp-embed&ver=4.9.4:670
    (anonymous) @ load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,thickbox,jquery-ui-tabs,wp-mediaelement,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp&load[]=-lists,postbox,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box,underscore,word-count,post,editor-expand,shor&load[]=tcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-api-request,media-views,media-editor,media-audiovideo,mce-view,im&load[]=gareaselect,image-edit,svg-painter,wp-auth-check,media-upload,jquery-ui-button,editor,quicktags,wplink,wp-embed&ver=4.9.4:670
    a @ tinymce.min.js?ver=4607-20180123:1
    p @ tinymce.min.js?ver=4607-20180123:1
  • Hi. As with others on the forum, with multiple ACF wysiwyg fields on a post, I am not able to access the Visual mode. The content displays only in Text mode.

    I don’t see any errors in Javascript Console.

    The only plugins I have installed are ACF Pro, jQuery UI Widgets, Updraft Plus, and Ninja Forms.

    The problem goes away when I deactivate Ninja Forms 3.2.16.

    Separately, I would like to request changing the text from “Click to initialize TinyMCE” to something more user-friendly. As a developer, I understand what this means, but as a user, my clients don’t necessarily know what TinyMCE is and the text is not intuitive. Perhaps something like “Click in the box to edit the content”.

    (Lastly, when I tried to start a new topic on this issue using John Huebner’s link above, I got an error “Failed to send” without any explanation.)

  • Did anyone figure this out?
    I temporarily turned off the editor, but my client really doesn’t know HTML and relies on it. Turning off ACF is not an option either…

    I read through this thread and I’m not using any of the plugins mentioned here.
    My version of ACF is

    My error code:

    Uncaught ReferenceError: pum_shortcode_ui is not defined
        at new <anonymous> (mce-buttons.min.js?wp-mce-4607-20180123:1)
        at k (wp-tinymce.php?c=1&ver=4607-20180123:14)
        at Array.<anonymous> (wp-tinymce.php?c=1&ver=4607-20180123:14)
        at Object.b [as each] (wp-tinymce.php?c=1&ver=4607-20180123:2)
        at m (wp-tinymce.php?c=1&ver=4607-20180123:14)
        at Object.r [as init] (wp-tinymce.php?c=1&ver=4607-20180123:14)
        at q.<anonymous> (wp-tinymce.php?c=1&ver=4607-20180123:14)
        at Array.<anonymous> (wp-tinymce.php?c=1&ver=4607-20180123:4)
        at b (wp-tinymce.php?c=1&ver=4607-20180123:2)
        at r (wp-tinymce.php?c=1&ver=4607-20180123:4)

    Any help would be SUPER! Thanks!

  • The error log points to an error with ‘pun_shortcode_ui’ which when I google it seems to refer to another plugin ‘PopupMaker’, maybe your issue is there?

    The solution for me, at least temporarily was to turn *off* the option to ‘Delay initializiation’ of TinyMCE, after doing this for each field things seem to work and I can live without that option.

  • Thanks @mooner for your help!
    I do have PopupMaker installed. I will check that.

    About “turn *off* the option to ‘Delay initializiation’ of TinyMCE”… how would I do that? I didn’t see an option in the admin so I’m guessing this is something I have to code?

    Thanks again!!!

  • Thanks again @mooner
    hmmm… I’m guessing this is the PRO version… better upgrade! 😉

  • I have the same problem, Current ACF Version is 5.8.7, How to rollback version, How to do it?

  • I successfully rolled back to version 5.6.9 and reported another error
    /wp-content/plugins/acf-qtranslate/assets/acf_5/main.js on line 2
    FileField is no undefined

Viewing 21 posts - 1 through 21 (of 21 total)

The topic ‘Can't click visual tab since latest update’ is closed to new replies.