Support

Account

Home Forums Add-ons Flexible Content Field Can't add new field in flexible field defined

Solving

Can't add new field in flexible field defined

  • Hi,

    I have problem with one big flexible content field with bunch of layouts defined inside. What I want is simply just insert one text field to one layout, but when I save fields, that field get out of flex field definition and get to be new top level field?

    The problem is that I don’t know how to even debug this, I think this could be some kind of BUG potentially

    Thanks for any ideas, and yeah, I captured it in short 30sec of your life gif:

    desc

  • Also,

    I’ve picked up json file that got saved in acf-json dir and I find out that field_XXX is not unique (like 30% duplicates) ? .. or should I ditch all this and start from scratch?

    desc

  • Bump..

  • You are definitely having an issue with duplicate field keys, i have see this happen when duplicating a field in one layout and then moving it into a different layout, but I have never found the cause. If you don’t have data saved in these fields yet then you’re best bet is to delete all of the fields with duplicated keys and recreate them. Another choice would be to edit the json file and make sure that all the keys are unique, you could simply tack on a 1, 2, 3 ect to each key, then update the date modified value in the json file and sync the field group. These are the things I’ve done in the past when I’ve had the issue but then I was in the middle of building and it was not on a site with live data to worry about yet.

  • No diec @hube2 unfortunately 🙁

    I had bad regex in finding keys in json file, this one is correct

    \"key\": \"field_.*\"

    because with “field_.*” I also selected “conditional_logic” fields (just refs and that’s just fine) 🙁

    File is semantically OK (AFAIK – no dups for sure) but also when I add this “Title” field in json (on position where I need it), increase timestamp on modified field admin interface is not reflecting the change (and no sync option is available) (there are other field groups that I get sync option)

    So now I’m lost with this issue more then before 🙁

  • Are you running into an issue with max_input_vars? This can be a problem on large groups of fields. Try installing this plugin and making edits. The plugin has not been updated in a while but it still works https://wordpress.org/plugins/wp-max-submit-protect/

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.