Support

Account

Home Forums Backend Issues (wp-admin) Bulk Update Custom Fields

Solved

Bulk Update Custom Fields

  • I imported over 750 posts into a custom post type from a CSV using a third party importing plugin. I was able to get everything imported and looking perfect in the backend, however, the relationship fields specifically are not showing up correctly in the front end (although they are looking 100% in the backend).

    I’ve done some experimentation and noticed that if I click “Update” on the post, the relationship shows correctly on the front-end. So, how do I bulk update my custom post type so that I don’t have to click “Update” 750 times? I’ve tried the basic bulk edit by selecting all the posts and adding a test tag, but that doesn’t do the trick.

    Any help would be much appreciated.

  • Are you running any kind of caching plugin? If so, try clearing the cache.

    Otherwise, see: https://wordpress.org/support/topic/update-all-posts-using-php-or-function

  • I have exactly the same problem, if anybody has a solution to this, I would be ever so grateful.

  • It happen something like that to me. Updating saves the data that was read fine from the DB to the post editor, but is not found in the front end until re-saved.

    The problem was my fields being created by code and there was a duplicate field key (duplicated on purpose – I assumed the source of the meta-custom field in the DB would be shared for both ACF fields).

    The duplicate field key doesn’t have to be THE ONE of the problem. Just by having one duplicate field key in the same group, it can ruin other fields (most probably the ones created later, not the ones before, since the hole in the array generated by one element using an existing key instead of another one affects the NEXT items in the array, not matching the original index… or so).

    Good luck.

  • Not sure why this has been marked solved this doesn’t work. If anyone else is having issues with this I’d love some help. Thanks!

  • Why is this not address nor solved for 7 years?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.