Support

Account

Home Forums ACF PRO Bug After Updating to 5.2.5 – Post's won't update or publish ??

Solved

Bug After Updating to 5.2.5 – Post's won't update or publish ??

  • After updating today to 5.2.5 , when we try and edit or publish a post or page , the update – publish button never finishes , the post / page won’t update or publish , if i click away , the post / page is shown as being a ‘draft’

    On my test site i rolled ACF back to an older version and it all works again ?

    What is the problem here ?

  • I am having the same problem.

  • Same, on all sites with 5.2.5

  • Confirmed as well. Posts are not updating due to a jquery error on post save.

  • We’re having the same issue on one of our sites as well. It will allow me to save a post as a draft, but whenever I attempt to publish it from the edit post page, the console log keeps infinitely loading this every 30 seconds or so and not publishing the post.

    POST http://********.com/wp-admin/admin-ajax.php
    {“wp-refresh-post-lock”:{“new_lock”:”1431706252:5″},”wp-auth-check”:true,”server_time”:1431706252}

    The site is running WordPress 4.2.2 and ACF 5.2.5. I reinstalled WP and ACF, just in case something was missing in the recent updates. It’s still not allowing me to publish from the edit post page. The interesting thing is it’s working on a few other sites we manage with the same configuration and plugins.

    I disabled the ACF plugin on the site that’s having an issue and it’s allowing me to publish from the edit post page. So the issue is definitely with ACF not playing well with WP in some way.

    A workaround is to save the post as a draft and then from the post lists quick edit, change the post status to published. That seems to be working.

    Any help to resolve this issue would be great. Thanks!

  • The issue appears to have resolved itself for our site — yet we changed nothing. Is there any explanation on ACF end as to why this was happening?

  • yeah , sorry . this has not been solved , it’s still broken , is anyone from ACF going to reply here ??

    I cannot update to the latest version

  • Hi guys,

    Thank you for reporting this issue, I am afraid I cannot replicate the issue from my end.

    @jrwdev can u please provide more information on the jQuery error? It would also help if you could do some testing to determine whether the issue is arising from a plugin conflict and deactivate all other plugins.

  • I deactivated all plugins and the problem remains , deactivate ACF and i can then publish and edit posts …. roll back to an older version of ACF and it works , so ACF seems to be the problem. Just tried the latest version 5.2.6 ..no fix.

    Uncaught TypeError: Cannot read property 'length' of undefinedm.extend.each 
    @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,farbtastic,quicktags,jquery-ui-core,jq…:2(anonymous function) 
    @ acf-input.min.js:2r 
    @ acf-input.min.js:1n 
    @ acf-input.min.js:1acf.apply_filters 
    @ acf-input.min.js:1acf.validation.acf.model.extend.fetch_success 
    @ acf-input.min.js:2acf.validation.acf.model.extend.fetch.$.ajax.success 
    @ acf-input.min.js:2m.Callbacks.j 
    @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,farbtastic,quicktags,jquery-ui-core,jq…:2m.Callbacks.k.fireWith 
    @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,farbtastic,quicktags,jquery-ui-core,jq…:2x 
    @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,farbtastic,quicktags,jquery-ui-core,jq…:4m.ajaxTransport.send.b 
    @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,farbtastic,quicktags,jquery-ui-core,jq…:4
  • I am getting the same error, but I am using ACF Pro 5.1.8 and WordPress 4.4.2. Has this been fixed in the latest version yet?

  • Hi @rugbert

    I’m using the latest version and can’t reproduce the issue. If you want to update it, please backup your site and database first.

    Thanks!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.