Support

Account

Home Forums Gutenberg Blocks not showing in Block Editor

Solved

Blocks not showing in Block Editor

  • I can’t open a ticket – I’m getting an error. So I’m resorting to forums.

    I have a problem with a site that is using ACF Gutenberg Blocks and has started showing “Your site doesn’t include support for the “acf/my-block-name” block. You can leave the block intact or remove it entirely.”

    HOWEVER, I can add new blocks of this type. These appear fine. It just won’t display existing ones.

    I’m using ACF Pro v5.9.4 on WP v5.5.3.

    I’m using acf_add_local_field_group() to load the fields from JSON files. (This was set up by a previous developer on the site).

    The block contains a repeater field. I don’t know if this is relevant.

    Have you seen this before? Do you know what’s wrong or how to fix it?

    Thanks

  • I was having this same issue on a site today and I just updated to the latest version of WordPress and it seems to have fixed it. I hope that helps!

  • Interesting. I just tried that on a locally hosted copy and yes. These blocks don’t load on WP5.5.3, but they do on WP5.6.

    That’s a bug right there, surely? Is WP5.6 required for ACF now?

    • karks88

    • January 20, 2021 at 12:39 am

    I’m getting the very same issue here on WP 5.5.3. I can add a new block and it shows up just fine, but existing ACF blocks on a page won’t load on the back end.

    • Elliot

    • January 29, 2021 at 3:07 pm

    Hi all πŸ‘‹. Thank you for your patience whilst we tested and debugged the issue.

    We have successfully identified this issue as a regression in ACF PRO 5.9.4 which caused ACF Blocks to be registered *after* the WP editor instance was initialized. This explains why new blocks could be added whilst existing blocks did not appear on page load.

    Whilst we continue testing of the fix, please find an updated JS file to copy and paste into the pro/assets/js/ folder within ACF PRO. This file contains the related patch and should solve the problem 100% – please comment bellow with your results. The quicker we can get positive feedback from you, the quicker we can release an update πŸ™Œ.

    Dropbox link will be available for 7 days: https://www.dropbox.com/t/gTRoawP1TRGUgXT3

    • Marlou

    • January 29, 2021 at 9:14 pm

    Hi Elliot,

    I experienced the same error on multiple sites (ACF pro v5.9.4 in combination with WP core v5.5.3 – (update to WordPress v5.6 fixes it)).

    I’ve just tested your fix (on local hosted sites) by downloading the acf-pro-blocks.min.js file and copy/pasting this in my pro/assets/js/ folder. However this doesn’t seem to have fixed the issue (tried this in 2 different websites so far).

    Hopefully Ross and others can test the fix as well.

    • Elliot

    • January 29, 2021 at 10:27 pm

    @mrrrlou Can you confirm your browser is not loading cached assets? Please perform a hard-refresh or try a unique browser. Thanks πŸ™

    • Marlou

    • January 29, 2021 at 11:09 pm

    I tried the following and nothing seems to resolve it:
    – hard refresh
    – testing in new incognito/private session (Chrome, my default browser)
    – testing in different/unique browser (Firefox)
    But maybe I’m overlooking something so I’m hoping the other users can test your fix as well.

    • Elliot

    • January 30, 2021 at 10:06 am

    @mrrrlou Thanks for the reply. Would it be possible to gain access to a staging version of your site for us to debug? Our local tests and showing this patch works, so I’m very interested in diagnosing the issue in your environment.

    One thing that did come to mind is perhaps you had copied the updated JS file into the /assets/js/ folder instead of the /pro/assets/js/ folder? Can you confirm that WP is definitely loading in this updated file?

    • Marlou

    • January 30, 2021 at 6:17 pm

    Ha I indeed copied it to /assets/js/ instead of /pro/assets/js/.
    My bad! The fix is working now! πŸ™‚

    • Elliot

    • January 31, 2021 at 11:19 am

    @mrrrlou Fantastic!

  • @elliot Can you share the updated file again ?

    I am encountering the same issue in my projects. And the file is no longer available.

    • Elliot

    • February 11, 2021 at 4:40 pm

    Hi all πŸ‘‹. ACF PRO v5.9.5 is now available and includes the above mentioned fix πŸŽ‰

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.