Support

Account

Home Forums Backend Issues (wp-admin) All field names empty

Solving

All field names empty

  • I updated to WP 5.2 and ACF Pro 5.8 this morning on both my local and staging sites. Now all of my field names across all field groups are empty. The data is still there, but if I try to add the field name back in, the data gets blanked out.

    This is really concerning, I’m not really sure how to move forward without wiping out all my data.

  • I’m having the exact same issue. WP 5.2 update happened and now multiple fields aren’t showing in wp-admin interface. Data still exists in FE. I’ve created a support ticket 2 days ago but so far no response…

  • I’ve found a temporary solution – I’ve installed the “Classic Editor” plugin and my fields are once again visible in wp-admin. Not ideal but works in the meantime until the bug is fixed.

  • Interesting, I’ve been using Classic Editor the whole time. Disabling and reenabling didn’t do anything.

  • Oh! Sorry it didn’t help… hopefully this bug will be fixed soon. It’s affected all the sites I’ve built with ACF Pro. V annoying!

  • I have not seen this on any sites running any of the themes or plugins that I use. I would guess that there is some incompatibility issue. But there really is no way of telling exactly what happened or why the field names are missing.

    If you did a backup I would first restore both sites.

    If you can’t do a restore, look in the DB, search the posts table for post_type = acf-field and look at the post_excerpt column. This is where the field names are store. Make sure the field names are still there and look correct. If they are not then, well, you’ve got huge issues.

    Then (or starting here if you cannot restore) I’d start with basic troubleshooting, deactivating other plugins and changing themes to see if I could narrow down where the problem might be.

  • Hi John,

    Thanks for the troubleshooting tips.

    On my local I do see all the acf-field posts, and their post_titles have content, but the post_excerpts are empty.

    I reimported one of the acf-json files and it seemed to work, all the field names are in post_excerpts, and I can see them in the Field Groups page. I updated back to 5.8 and it’s still fine.

    I went to test this on staging but it didn’t work. Then I remembered I had downgraded my local ACF to 5.7.13. So I tried downgrading on staging but that didn’t work either. I even tried deleting and reinstalling ACF. I tried with all plugins deactivated, and with them active. Here are the ones I have installed:

    ACF Pro
    Classic Editor
    Disable Emojis (GDPR friendly)
    Safe SVG
    WordPress Importer
    WP Sync DB
    WP Sync DB Media Files
    Yoast SEO

    I’ve built a ton of sites using some combo or all of the above plugins, and more. I’m kind of at a loss for what to do next. Luckily if it all goes to shit I’m only down the home page content as I’ve just started on this project. I can push my local db up to stage and probably fix it that way, still kind of nerve wracking.

    Thanks again.

  • My guess is that it’s something in the theme, but that’s only a guess, some type of filter that is altering post excerpts. If it were me and I had just started building the site I would just delete the groups and import them if I have json files, however, that will not solve your problem since it might happen again if you don’t figure it out.

    I would keep trying to do whatever you did that made them disappear with different themes/plugins enabled to figure out what caused it. other than that, I don’t think I’ll be of much help. If you can tell me exactly the steps and what combination causes it I might be able to help more, but you’re going to have to narrow it down.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.