Support

Account

Home Forums Backend Issues (wp-admin) Adding ACF Taxonomy field for existing Taxonomy

Solved

Adding ACF Taxonomy field for existing Taxonomy

  • We have a taxonomy that is already associated with a custom post type. The posts within that custom post type have many associations to that taxonomy. This works.

    We have added an ACF field that is tied to that taxonomy in order to provide a nicer user experience for editing posts.

    The problem is, when the user loads the edit post screen, the taxonomy values do not pre-populate from the saved DB settings into the new ACF Taxonomy field.

    If the user selects new taxonomy values within the ACF selector, upon post update, it saves to the correct taxonomy field but wipes out the other taxonomy values that existed previously. This is a big problem for us.

    I can see that the taxonomy values are there because I’ve got the built-in taxonomy screen on the right hand sidebar. I know that I have the right field name because the taxonomy field gets updated when the user updates the post.

    Here are my ACF field settings:

    • Label: Country
    • Name: country (this is the same as my custom taxonomy)
    • Type: Taxonomy
    • Required: No
    • Taxonomy: country
    • Appearance: Checkbox
    • Allow Null?: No
    • Create Terms: Yes
    • Sync Terms: Yes (double checked this)
    • Return Value: Term ID
    • Conditional Logic: No

    ACF Ver: 5.2.5
    WP Ver: 4.2.2

    How can I get the ACF field to pre-populate/sync with the taxonomy values within the database? I really don’t want to ask my client to re-enter hours of information that already exists in the database.

    THank you in advance for your help,

  • When creating a taxonomy field there are three settings that control saving and loading terms. See the attached image.

    You want to set Load Terms to Yes

  • Ah, “Load Terms” did not exist for me in 5.2.6, updating ACF to 5.2.7 added this option and it appears to be working. Thank you.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.