Support

Account

Home Forums Backend Issues (wp-admin) "Add to gallery" button not working on iOS?

Solving

"Add to gallery" button not working on iOS?

  • Hi,

    I’ve got a Gallery field wrapped in a Flexible Content field and I just noticed that the “Add to gallery”-buttons aren’t working on iOS. Clicking the buttons in mobile Safari on an iPhone does nothing… It won’t throw an error. Nothing.

    Simulating a click-event on the buttons with jQuery’s $.click() actually fires the media popup properly. However I can’t close it properly either. The “X” button is also not responding. So, yeah, I guess it has something do with touch events? Funny thing is everything is working just fine in the iOS Simulator…

    Is this a known issue? Does ACF not support editing on mobile/touch or should I be looking elsewhere for the cause of this problem?

    Kind regards,
    Daniel

  • I know this is an older issue, I’m working on replying to some of the older ones.

    Are you still seeing this with the newest version of ACF and what version are you using.

  • Hi John,

    Thank you for your reply. This is still very much an issue I’m afraid… I just tried it and the upload/editing modal still won’t appear for me when clicking on the “Add to gallery”-button or when I’m trying to “edit” an image in the Gallery field.

    Being an older issue I can’t recall what version was used at the time. Right now the site is running ACF Pro 5.2.7 though. Please let me know if I can supply any additional info or anything in order to help out.

    Edit: By the way I’m having this issue on iPhone and haven’t tried it out on iPad yet. It was reported to me specifically as a smartphone issue though.

  • I will report this as a bug to the Developer, he may have additional questions.

  • Hi there,

    Just noticed this issue on a front end form running the latest version of ACF. Regular image upload field works fine, but the Gallery field doesn’t work at all… It’d be great to get this resolved 🙂 Let me know if you need any more information.

  • Has this issue been resolved yet?

    The Gallery field is useless on mobile devices…

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.