Support

Account

Home Forums Backend Issues (wp-admin) Add image repeater issue iPad

Solving

Add image repeater issue iPad

  • Morning,

    I have an issue with WP 3.6, ACF 4.2.2, Repeater 1.1 – If I have an image field type inside a repeater. When using an iPad, pushing the button does not trigger the upload/add media box.

    Adding an image, using the standard add media will work, also using the ‘image’ field type outside of a repeater also works. It’s just within the repeater there is an issue.

    This issue is not present on any browsers on a windows machine.

  • Hi @drsolutions

    Can you check for any JS errors on the page? I believe you can also use the inspector on an iPad.

    Any JS error will prevent the button from working.
    That will be a good start to finding the issue. If it’s any consolation, I have not heard of this issue before, so hopefully it is a specific conflict on your site which can be fixed.

    Thanks
    E

  • Hi Elliot,

    I have checked all of our sites which are up to date with WP and your plugin and they all have the issue. Sorry to be the bearer of that news.

    After installing developer tools and running as an iPad (user agent only) the following information was revealed. I only have windows machines and to run the device as itself via my machine requires Safari 6 which you cannot get on Windows.

    http://www.drsolutions.co.uk/before-click.png
    http://www.drsolutions.co.uk/after-click.png (the native app option takes you to WordPress for iOS app, after testing this does not load acf fields)

    So as a summary, the main add media button on the generic page allows access to the media window to take or pick a picture. The single acf image field also allows access to the media window. Only when trying to use the image field in the repeater its doesn’t trigger.

    Sorry I cannot debug any further… Very frustrating.

    Travis

  • Hi @drsolutions

    Thanks for the screenshots – very helpful.

    I’m not sure when I’ll be able to look into this issue as I must prioritize others above it.

    Does clicking on the 2 tabs (Upload Files / Media Library) allow you to select / upload?

  • Morning Elliot,

    I can select from the iPad’s image library and also take a picture. All normal facilities work.

    Hope you can look at this again soon.

    Travis

  • Morning Elliot,

    Any news on this item?

    Travis

  • Hi @drsolutions

    No news. Like I said “I’m not sure when I’ll be able to look into this issue as I must prioritize others above it.”

    I am not going to be able to find a solution for this anytime soon and I apologize now for the inconvinience. Please find it in your heart to understand that there are many other issues which must first be address before testing ipad media uploading.

    FYI: I don’t have time to work on ACF full time, only a small part of the day.

    Thanks
    E

  • Hello,
    I met this bug last night.

    I don’t figure out why the event click doesn’t fire in iPad in this case (image field in repeater field).

    I even add a script to see what happen on iPad when we click on this input :

    
    $(document).on('click', function(e){
        console.log(e.target);
        // All devices return : <input type="button" class="button add-image" value="Ajouter une image"> // NB French locale
        // iPad return nothing
    })
    

    The only way i found to fire the onclick is to add a touchstart event like following :

    
    // input.js ; line 2831
    $(document).on('click touchstart', '.acf-image-uploader .add-image', function( e ){
        e.preventDefault();
        acf.fields.image.set({ $el : $(this).closest('.acf-image-uploader') }).popup();
    });
    

    And it works.

  • @flo where did you paste this code? thanks

    A

    EDIT: Nevermind, skimmed past the input.js part

  • I have done the same as iPad and other tablets require touchstart or touchend to fire off for functions to work. Works a treat now.

  • Hello. I’m experiencing the same issue. Because it was happening on a site with quite a few Plugins, I installed a fresh copy of WordPress with only Advanced Custom Fields and the Repeater Field Add-on. With only those two plugins, and the base 2014 theme, I’m unable to get the image nested inside of the Repeater to work. If I use only the image field, the single image works fine by popping-up the Media Library. The “Add Row” button does work, but then the “Add Image” button doesn’t trigger.

    I attempted to use the JS noted above inside appended to the input.js file, but that doesn’t seem to help either.

    Thank you,
    -Thomas

  • I just wanted to check-in and see if there’s any news regarding this. Today, I tried again with a fresh install of WP4 and used only Advanced Custom Fields and the Repeater Field Add-on to attempt to add multiple images using an iPad and/or iPhone.
    I also tried adding the code above to the input.js and separately as a another JS file with no success. A single image button outside of the Repeater Fields seems to work as expected.
    If there’s other code to add in order to get it to work, I would greatly appreciate it.

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Add image repeater issue iPad’ is closed to new replies.