Home Forums Backend Issues (wp-admin) ACFs will not save.


ACFs will not save.

  • I’m having an issue where I edit custom fields settings such as hide on screen, “add row”, etc.. and when I save the changes aren’t applied.

    I’ve been exporting my ACFs via the PHP export feature so some of the names I’m rewriting there but I cannot figure out why this is happening.

    I’ve deleted the plugin, re-installed, re-imported the fields, repaired my tables, a and duplicated the field group with no luck.

  • Update
    I found this thread:

    But it hasn’t resolve my issue.

    In case it helps I’ve attached my ACF XML export for review.

  • Hi @emaildano,

    Can I get some more info to what is happening on save please?

    Are you getting any PHP errors in your logs or in the browser?

  • No errors, but I do think I narrowed down where the issue is coming from.

    When I add a repeater field inside of a flexible content field, it breaks and will not save. Also, it reverts some of the custom settings such as the ‘add row’ title, etc..

    Is there a bug report for nesting repeater fields inside of flexible content fields?

  • Hi @emaildano

    Thanks for the attached xml. I can see that your flexible content filed contains a lot of sub fields and sub field data!

    it is most likely the size of this array which is causing the save function to break.

    The good news is that this issue wont occur in ACF5, however this is a few months away from release…

    Perhaps for now, you will have to simplify your flexible content field, or upgrade your servers vars / PHP memory.


  • Elliot,

    This is overdue but I found an issue to this problem.

    It comes from the max_input_var located in the php.ini file.

    I’m using PHP v 5.4.4 which required adding the following line to the php.ini file to support saving fields that exceed the default limit. I’m not sure what the default is but here’s what I’m using now.

    max_input_var = 100000


Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘ACFs will not save.’ is closed to new replies.