Support

Account

Home Forums Backend Issues (wp-admin) ACF, Yoast & WooCommerce

Solved

ACF, Yoast & WooCommerce

  • Hello!

    I have been dealing with a fairly frustrating problem for a little while now, and figured I’d see if anyone has a solution.

    Currently I have to disable ACF in order to make any changes to the product gallery or Yoast settings, which in turn breaks the site because I use the ACF fields to populate a lot of the product data.

    Here’s what I’m up against:

    WooCommerce – Cannot add photos to gallery, cannot access product data tabs via product page. (Unless ACF is disabled)
    Yoast – Cannot do anything via product page. (Unless ACF is disabled)

    This applies to both my local dev environment as well as the live site.

    Local Dev Server (Bedrock & Trellis)

    • WooCommerce Version: 2.6.2
    • WordPress Version: 4.5.3
    • WP Memory Limit: 256 MB
    • Server Info: nginx/1.9.14
    • PHP Version: 7.0.5-2+deb.sury.org~trusty+1

    Remote Live Server (Cloudways)

    • WooCommerce Version: 2.6.2
    • WordPress Version: 4.5.3
    • WP Memory Limit: 256 MB
    • Server Info: Apache/2.2.22 (Debian)
    • PHP Version: 5.6.23-1~dotdeb+7.1

    Active Plugins

    • Redux Framework by Team Redux – 3.6.0.2
    • Advanced Custom Fields by Elliot Condon – 4.4.7
    • Akismet by Automattic – 3.1.11
    • FacetWP by FacetWP, LLC – 2.5.3
    • WooThumbs – Awesome Product Imagery by James Kemp – 4.4.13
    • Roots Wrapper Toolbar by Nick Fox – 2.0.0
    • WooCommerce by WooThemes – 2.6.2
    • WooZone – WooCommerce Amazon Affiliates by AA-Team – 9.0.2.1
    • Yoast SEO by Team Yoast – 3.3.4
    • Wordfence Security by Wordfence – 6.1.10
    • WP Rocket by WP Rocket – 2.8.8

    Theme
    Sage starter theme

    Both WP installs are basically the same except I don’t have the akismet, caching or security plugins on my local install.

    I have tried disabling individual plugins to see which one causes an issue. Problems go away after disabling ACF. Also tried installing Yoast’s ACF plugin which didn’t help.

    Thanks!

  • From console of product page:

    JQMIGRATE: Migrate is installed, version 1.4.1 load-scripts.php:9:542

    ReferenceError: acf is not defined
    post.php:215:2

    Prefixed Fullscreen API is deprecated. Please use unprefixed API for fullscreen.

    For more help https://developer.mozilla.org/en-US/docs/Web/API/Fullscreen_API load-scripts.php:387:6458
    TypeError: acf.o is null
    input.min.js:1:7148

  • I’m beginning to think it has to do with the order that some js is loaded as referenced by this post:

    https://support.advancedcustomfields.com/forums/topic/uncaught-referenceerror-acf-is-not-defined/

    I’m going to look into it a bit more this evening and report back my findings.

    Please don’t let that stop anyone from commenting and/or helping out!

  • Ok, the problem stemmed from some custom code I added to defer parsing of js.

    I commented it out, and now everything works as it should.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.