Support

Account

Home Forums ACF PRO ACF v5 PRO – ACF qTranslate problem

Solving

ACF v5 PRO – ACF qTranslate problem

  • Hi guys, i’ve installed ACF v5 PRO and i created around 10 custom fields group, after that i had to set a qTranslate text field and i noticed that i can’t see them anymore on the custom field list, i tried to rollback to v4 and qTranslate fields shows up, the problem is that i can’t rollback to v4 because my fields group were made with v5 and i can’t see them with v4, is there a quick fix to have qTranslate ACF fields with v5 or a way to import the json (exported fields file) from v5 to v4 ?
    Thanks
    Andrea

  • Hi @serraniandrea

    It is not possible to downgrade the data from ACF PRO to ACF4, however it is possible to use the export to PHP feature as both ACF PRO adn ACF4 use the same code format.

    As for the original question, I’m not sure I understand what is going wrong.
    What do you mean by set a qTranslate text field?

    I have tested qTranslate with ACF PRO and the ACF fields appeared on both languages. Perhaps you can include steps to replicate the issue?

  • I’ve just released an updated version of the ACF qTranslate plugin with v5 support.
    http://wordpress.org/plugins/acf-qtranslate/

  • ACF qTranslate plugin is not working with v5, when i try to save my post, the page not save.

    Are you know which is the problem?

  • I’m bumping into a similar problem. I have a page with a Repeater field from ACF. The Repeater field has two subfields, a qTranslate text field, and a qTranslate textarea field. When I try to save the post, it would not save, and shows “Connection Lost” error message.

    I’m working with

    • WordPress 4.0.1
    • ACF PRO 5.1.5
    • qTranslate Plus (modified qTranslate to support WP4)
    • ACF qTranslate 1.4, but modified to work with qTranslate Plus
  • FYI, ACF qTranslate is providing ACF additional field types, shown as in the screenshot attached.

  • Yup, ACF V5 PRO and ACF qTranslate wont play nice (at least with qTranslate Plus). Had to go back to ACF v4 so everything works good.

    Won’t work: WP 4.1.1 + ACF PRO 5.1.7.1 + Advanced Custom Fields: qTranslate 1.4 + qTranslate Plus 2.7.2 inc. Patches
    Works: WP 4.1.1 + ACF 4.4.0 + Advanced Custom Fields: qTranslate 1.4 + qTranslate Plus 2.7.2 inc. Patches

    It looks like “ACF5PRO” is not recognising the new fields created by “Advanced Custom Fields: qTranslate 1.4”, so when you assign them and save your custom fields, they appear as regular ones. Then the editor will break apart silently.

    Please let me know if this gets fixed, since ACF5PRO was playing great.

    Thanks!

  • The latest version now works with ACF5, qTranslate Plus and qTranslate-X.

  • Great news! Thanks for the update funkjedi πŸ™‚

  • Great funkjedi! Thanks you!

  • http://awesomescreenshot.com/0414sdmva8

    still doesn’t work. fields saving not correct

    ACF Pro
    qTranslate – X
    ACF Qtranslate
    all plugins are latest version

    p.s. Sorry for my english

  • when I saved fields without “#” symbol in the and was added “#” in fields

    see screenshot
    http://awesomescreenshot.com/0984sdnn35

  • I still have a problem saving “file” fields. When “act qtranslate” plugin is active, the field just returns empty after saving. If the plugin is turned off, i can save the “file” field with no problems.

    Any way we can solve this?

    I would love it if i could choose in the plugin settings what custom fields i want to exclude from qtranslate. That would be an easy fix to my problem because i don’t need a file field translated anyway πŸ™‚

    EDIT: I just updated the q-translate-x plugin, and that has solved the problem. Because now you can exclude the act fields and post types you don’t want to translate . Perfect.

  • I am loving ACF5 and acf-qtranslate plugins thanks all involved.

    I am having the same issue where the the repeater and even the flexable content – does not want to update when the post is saved – it renders blank.

    I have the following versions and I am working on a local MAMP PRO installation.

    Wordpress – (4.2.2)
    ACF5 Pro: – (5.2.6)
    acf-qtranslate: – (1.7.9)
    qTranslate X – (3.3)
    PHP – (5.6.7)
    Chrome – (43.0.2357.124)

    Anything I can try?

    Thanks in Advance.

  • I am also facing the same issue. I was using ACF4. And, issue arises with fields in Repeater and Flexible fields. Then I upgraded to ACF Pro. Still issue was same. So, I changed a field from ACF-Qtranslate to Text, and it works fine.

    My current environment:
    – WordPress 4.2.2
    – Advanced Custom Fields Pro 5.2.7
    – qTranslate-X 3.3
    – Advanced Custom Fields: qTranslate 1.7.9

    Fields are still not saving.

  • Hello! I have problem with Wysiwyg Editor when I’m using WordPress 4.9.5 + ACF PRO (Version 5.6.10) + qTranslate-X (Version 3.4.6.8) + Advanced Custom Fields: qTranslate (Version 1.7.23).

    If I choose tabs Visual $ Text in field settings:
    On post/page edit page in Wysiwyg Editor I see the only tabs and not formatted text in text area, and no toolbars.
    If I click on any tab, visual or text in Wysiwyg Editor the toolbars become visible.

    If I choose single tab Visual OR Text in field settings:
    On post/page edit page in Wysiwyg Editor I see the only not formatted text in text area, and no toolbars.
    And if I’m trying to click somewhere on Wysiwyg Editor the toolbars are not appear.

    I can send screen video πŸ™‚

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.