Support

Account

Home Forums ACF PRO ACF Pro upgrade – flexible content not imported

Solving

ACF Pro upgrade – flexible content not imported

  • Thank you for the free upgrade and the GREAT plugin, btw!

    In an attempt to install ACF Pro I’m losing some custom fields. I deactivated all of the old ACF plugins, then activated ACF Pro, and it did the database thing. Sometimes the gallery field comes through as a text field. If I set it to a gallery field, it grabs the old data. That’s ok, but it would be better if it remembered it was a gallery.

    My big issue it with the flexible content field. On one site, with just text and textarea fields, the flexible content upgraded fine. I have another site that has flexible content with text, textarea, wysiwyg, post_object, and image fields. This one lost the entire flexible content area and set it to a text field. If I set it back to flexible content, it is blank. I will admit I didn’t try to rebuild the flexible content to see if it would grab the data, I just reverted the database because there is a lot of content to re-enter.

    I used BackupBuddy and reverted the database back, so we are back up with ACF 4. I want to upgrade to ACF Pro, but I don’t want to have to rebuild field sets or re-enter the content. How can I get you more information to help you debug this? I have 15+ sites that are running ACF in various forms of these add-ons. I am only on site 2 of updating to ACF Pro. I love this plugin, and as a programmer I know that sometimes there are bugs. That’s ok. I just want to help you figure this out so that the flexible content gets loaded back in through the transition correctly for everyone else!

    • Elliot

    • July 11, 2014 at 11:02 am

    Hi @debdstripe

    Thanks for the bug report. This will take some debugging but I’m sure we can figure out what is going on.

    My first idea is that the upgrade script is causing multiple fields to obtain the same field_key. This may explain why field settings are not loaded correctly.

    Are you able to perform the upgrade again and check your wp_post table. Order the table via the post_type and find the acf-field posts. Do any of them have the same post_name?

  • Anywhere that there is a gallery, it gets set to “text” after the update to PRO. Then I have to go into the custom field and set it back to “gallery”. It finds the content if I do this. Actually, on second look, one gallery kept it’s gallery setting. The one gallery that kept it’s gallery setting is only associated with one page. The other two galleries are for blog posts and a portfolio cpt. So, maybe pages are keeping the gallery and posts are not. All 3 gallery fields in the site are in different custom fields. All 3 have different gallery names, and all custom fields have different titles and post_names – double checked in the database.

    The flexible content is being set to “text” as well. Setting it to “flexible content” creates an empty flexible content area. If I look in the wp_postmeta table, the flexible content fields that were entered with that page by ID are still there, so I suppose if I rebuilt the entire flexible content custom field, it may pick up the data from the database.

    The post_names are all still exactly the same as when the site was running ACF 4, and none of them are repeats.

    It seems that the flexible content and gallery fields are more often than not defaulting to the “text” custom field when the move happens. This may be where the problem is happening? The one repeater that I have on this site associated with a page kept its value.

    The flexible content field I have contains: layout 1: image, text, wysiwyg. layout 2 : post_object. layout 3: image, text. There are 39 total entries associated with this specific page, mixed between the different layouts.

    Please let me know how I can provide you more information to help debug this, thanks so much!

  • Ok, I’ve tried updating another site to ACF PRO, and the repeaters and flexible content fields are still coming up as “text”. When I set them back to the right field, they have empty content.

    In one of the repeaters I tried to recreate the custom fields. The repeater had 3 fields ( Text, TextArea and Image). When I clicked update, it added the fields I just typed in, and the originals popped in but it odd places. 2 of the old repeater fields showed up on the root level, and then 4 were left in the repeater with one of them doubled up.

    When I went to the post that should contain repeater content already, it offers the ability to add content now, but the content that was loaded in there is blank. The information is still in the database, but I think because each field has a key (‘key’ => ‘field_53a87d540e730’ ) the keys aren’t matching up even if I recreate the repeater with the same field names.

  • Ok! Trying one of the sites that imported wrong with ACF PRO 5.0.1. A LOT of things are working much better, great job!!

    The repeaters seem to be coming through right.

    Galleries are coming through as galleries, YAY!

    A few of the Flexible Content fields are NOT importing and are instead converting to a text field. The one in question has a lot of entries with long field names, not sure why that would matter, though. It is attached to a CPT.

    The Flexible content field associated with Blog Posts is not importing – although the Repeaters and Flex Content areas with Pages are importing.
    The “Message” Fields in this site are showing as empty text fields? This wasn’t happening with 5.0.0?

    Relationship fields are not importing – setting to text fields.

    The site that I am trying to upgrade to ACF PRO hasn’t been launched yet, if you want access to run backup buddy and then try the ACF PRO upgrade, I can give you access. I could give you access to the database as well, if you want to see what is happening. This is a fairly complicated ACF site – could be useful. I would just need you to revert the database when you are done.

    • Elliot

    • July 22, 2014 at 1:55 pm

    Hi @debdstripe

    Thanks for the feedback. Yes please, if you can provide an account, that would be great.

    Cheers
    E

  • I sent an email with more information. Please let me know if you didn’t get it!

    • Elliot

    • July 30, 2014 at 2:05 pm

    Hi @debdstripe

    Yep, I’ve got the email and we can continue the conversation by email.

    Cheers
    E

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.