Support

Account

Home Forums ACF PRO ACF Pro unresponsive

Solving

ACF Pro unresponsive

  • I am unable to edit the home page that uses ACF Pro fields. In troubleshooting, when I try to edit the field groups, I am unable to add a field, rule, edit anything. The options are unresponsive. We’re using Classic Editor ver 1.5. Any known conflicts? Happy for any advice in troubleshooting. Thanks!

  • It sounds like you are experiencing a JavaScript conflict. This can also happen if there are any JS errors on the page at all. It’s hard to say what could be casing it. You’ll need to look in your console and see what errors are reported. However, I doubt it is classic editor, more than likely it’s another plugin or something in the theme that is the cause.

  • I am having the same issue, I checked the error logs on the server and there was nothing there regarding ACF. I also tried deactivating my other plugins and that also did not fix it. The console error is:

    Uncaught ReferenceError: acf is not defined
    at post.php?post=39&action=edit:3109

    Which seems weird, the only recent action I’ve taken regarding ACF is updating it to the newest version, is it possible the update caused this issue?

  • There are a few possibles.

    The first is that you’re browser may be trying to used cached versions of scripts, try clearing your browser cache.

    The second is that something could have been corrupted during the update process. Try updating again. You may need to log into your account and download/upload ACF that way to fix it this is the case.

    You could still have another script issue. Is there any other issue before the error you listed?

  • There were no other errors in the console and I had tried clearing my cache as well with no success.

    What weirdly worked is deleting ACF Pro entirely and reinstalling an older version from a backup I had taken before the recent update, then using healthcheck plugin to test any interactions between plugins and now the previous version is working fine.

    I’m going to try to download a fresh version of the new version this weekend and try with the new version again.

  • While it does not happen often, it is possible for files to be corrupted during the update process. I have had it happen to me in the past. Usually when it happens the file is truncated. Even individual lines can be truncated. Not sure how this happens. When corruption happens it usually happens to very large files.

    Another way to test out if there is a corrupt JS file is to add

    
    define('SCRIPT_DEBUG', true);
    

    to your wp-config.php file. This will cause WP to load unminified versions of scripts. If it works like this then one of the minified scripts is likely corrupt.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.