Home Forums ACF PRO ACF Pro New Fields Don't Update on Existing Pages


ACF Pro New Fields Don't Update on Existing Pages

  • I’m on ACF Pro 5.0.8 and WP 4.0 and noticed when I updated a new field on a field group, it never actually updates on each page. It seems to only have the first set of fields I created when I initially made the new field group. I also tried making a new page, but the same first set of fields were there. No options on that field group seem to update either.

    Any thought why this would be happening?

  • Hi @corbin

    This sounds quite strange, has this issue started at the same time as any milestone on the website (plugin update, etc)?

    Just to clarify, when you edit a field group and create a new field, the field appears fine and can be edited, but when editing a post, the new field is not visible?

  • I am running in to this same issue.

    I’m running WP version 4.5 and ACF Pro version 5.3.7

    I am going to troubleshoot this further this evening and will check back in with you, but I’m curious if you could save me some time with a fix that has already been discovered.

    My scenario:

    I have a page template set up with custom fields and all is well. I need to change content headers from static text to editable fields. I create new fields in my field group and save. The new fields are present in my field group and everything looks fine.

    The new fields do not show up in my page template in the page editor for existing pages or new pages. I have flushed the cache, tried activating the parent theme and then the child theme again, nothing seems to reset the field group and show my new fields.

    I don’t have much content using this field group so I could re-create the group and move forward, but I shouldn’t have to. Is there a reason that field groups that are already in use will not update when modified?

    I’ll check back in later this evening with a solution…or more questions.

    Thank you for all you do! This plugin is awesome 🙂

  • I don’t know of the solution in this specific case because the fact that you tried switching themes means that what I think might cause it does not make much sense.

    This can happen if you have enabled local JSON files by creating the acf-json folder in your theme and ACF is unable to overwrite the existing JSON file for the field group. This causes ACF to use the old version in the acf-json folder instead of the new version from the database on posts, but ACF will show the updated version in the editor.

    If you have acf-json folders in your themes, delete the folders from the server. If this is the cause of your problem then it should be solved. If it is then you need to find out what the write permissions of the folder and/or existing files in the folder. It seems that if they are created by ACF in the first place that ACF should be able to overwrite them.

    If this isn’t the problem, then any information you can provide about your effort to solve it might help others.

  • This wound up being a problem for me that was not caused by ACF. My issue was the ridiculous caching that is going on with my site. We are using Pantheon, the Pantheon caching Varnish, and then WP Supercache for our CDN. I have resolved my issue and I hope that it may help someone else in the future.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘ACF Pro New Fields Don't Update on Existing Pages’ is closed to new replies.