Home Forums Backend Issues (wp-admin) ACF post category – Posts are not saving 1st time I publish


ACF post category – Posts are not saving 1st time I publish

  • I’m developing a wordpress site and i’m facing an issue with Advanced Custom Field that I can’t figure out.

    I have a category called “nature” and I have create a field using the ACF plugin and set the following rule: POST CATEGORY IS EQUAL TO NATURE.

    So, everytime I create a new post and then, inside the post, select the category “nature” at the right bar, it shows the custom fields right away (like ajax or something). The fields just shows. I thought that everything was fine, but there is one major problem with that.

    I fill the fields with information, upload images and so on and then I publish. But it doesn’t save the first time I leave the post. It just works fine if I edit the post again and retype and resend all the images and then update the post.

    It’s not a custom post type. It is an ordinary post. The loops shows only the post title, but none of the custom fields are being showed after the first time I publish. Only if I fill everything again.

    I’ve tried everything (reinstalled the plugin, the theme, the group of fields) but It just does not work. Can someone help me with that?

    Thanks a lot.

  • There have been other reports of this. I have not been able to recreate it.

    What WP editor are you using? Gutenberg or Classic editor?

  • I’m facing the exactly same issue as the guy above. I’ve installed the classic editor plugin and now everything is working fine in classic editor. The ideal scenario would be using gutenberg because of the blog though.

    Thank you so much.

  • If it has to do with guberbug then your best bet is to contact the developers. There are few issues with it that still need to be worked out.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.