Support

Account

Home Forums ACF PRO acf-json not updating

Solving

acf-json not updating

  • Hi there! The file on the acf-json folder is not updating anymore. I am missing something? It used to work…

  • Hi @joanboluda

    Is it possible the file permissions on your server has changed? Perhaps you’ve switched hosting or your host has done some updating.

    Make sure the file permissions are 755 on the acf-json folder and that ACF has the ability to write to it.

    You could also activate WP debug and see if there’s any information coming from that. Put this in your wp-config.php file:

    
    // Turns WordPress debugging on
    define('WP_DEBUG', true);
    
    // Tells WordPress to log everything to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Doesn't force the PHP 'display_errors' variable to be on
    define('WP_DEBUG_DISPLAY', false);
    
    // Hides errors from being displayed on-screen
    @ini_set('display_errors', 0);
    
  • Hi Jonathan!

    Yeah, I tried. Checking permissions, activating debug mode, but nothing. And it used to work… maybe was after updating? I even tried deleting the file, but it doesn’t create the new one… And deleting the folder and creating it again… but nothing.

    Can you take a look, please? I can give you access to the admin and the FTP.

    Thanks!

  • Hello? Any help, please?

  • Please, I would love some support from the developer.

    Thanks.

  • Hi @joanboluda

    Sorry for the quiet time there for a bit 🙂

    Could you try reinstalling ACF Pro as well?
    If you head to the acf field group list, is there anything in the “sync” tab?

  • Ho Jonathan!

    Ok, no problem. But reinstalling is not working. And there is no “Sync” tab at the ACF group list.

  • Hello? Any help, please? It has been 2 days…

  • Hi @joanboluda

    Since there is no payed support it can take some time here for trickier subjects so please be patient with us 🙂

    I can’t really think of more debugging to do if you’re not seeing anything in the error log etc. Perhaps your hosting has changed something which now makes it unable to save files. Are you able to install new plugins directly from the admin? If not it’s pretty much certain that the issue lies with your hosting.

  • Hi Jonathan!

    Sorry, since I bought the premium I thought I paid for support. My fault.

    Yeah, I can install plugins, no problem. The problem is since last update. Buen what is that “Sync” tab you say? I really don’t see anything like that.

    Can I give you access to take a look?

    Thanks for your time.

  • Unfortunately premium is not support included however we are a few guys working the forums as best we can as an extra job on top of our regular jobs 🙂

    I’m not sure wether I’ll be able to find anything you haven’t if you’ve already did this extensive testing but I can have a quick look.

    Could you try something a bit drastic.. install a fresh WP installation in a subdomain or subfolder in the same hosting and see if the problem exists there as well.

  • Again… can you tell me something about that “Sync” tab? Where should it be? I don’t see it at all…

  • Basically.. when you have a json file which is out of sync with the ACF fields you have in your DB a “sync” menu item appears above the field groups (like the “trash” menu item in posts lists whenever you have trashed some posts).

    It was just a thought wether you had issues with syncing but since you’ve deleted the files all together it does not matter

  • I know it’s too late for the topic starter but I had a similar issue today and I bumped to this post, so I thought it might help somebody else if I shared my solution. In my case it was caused because my theme’s folder had different owner (probably due to the fact that I uploaded the theme via ftp). As soon as I chown’d the correct permissions it worked.

  • Facing same problem here, but not related to permission.

  • Switching acf-json dir perms to 777 worked for me for local dev

    Deploy via git, so I think dir perms will get reset to 755 on the server. We make all changes to ACF config locally, so not a big deal if doesn’t work on staging/prod. Will check though!

    Maybe something up w/ my group perms that 755 doesn’t work, but afaict looks good

  • I had the same problem, the reason was wrong owner / group settings for the folder.

    If you find that chmod 777 would work, changing to the right chown owner:group, chmod 755 will do fine again.

  • Hi, i’ve found something, but i don’t know if is your case.

    I’m using acf-pro on a mulsite enviroment and i’ve found and issue when using child themes.

    Scenario: i want to create and modify my custom fields on my parent theme, localhost, and show on wp-admin for users but don’t let they change the fields on server, so i decided to use acf-json.

    When i’m using the same theme, it works fine, but when i’m using child themes, the fields do not update.

    Testing my site i’ve found that when i’m using child themes, the fields are saved to “current” theme, even if the current theme is a child theme.

    Change the default save and load options, from “get_stylesheet_directory()/acf-json” to “get_TEMPLATE_directory()/acf-json”.

    The function get_template_directory() returns the main directory for the theme if is parent and the parent_directory if is a child theme, so now it works fine and i can control my fields only in the parent theme.
    Hope it can help you! 😉

  • Thought I’d add a little extra to this ticket for anyone else in the future. I use the JSON options on a ton of sites and run into the usual permission issue on the odd occasion but on one site my std install (a seperate file with acf filters and hooks) stopped syncing.

    The file was loading correctly which is called into the theme on the functions page and loads

    		add_filter( 'acf/settings/save_json', array( $this, '_acf_json_save_point' ) );
    		add_filter( 'acf/settings/load_json', array( $this, '_acf_json_load_point' ) );

    But for some reason while my class was loading these filters were not firing. Turns out there was a line above including my file that was using get_field an ACF function. Because this ran the filters did not load.

    So in my case this would not work (BAD EXAMPLE)

    
    define( 'MAIN_SITE_URL', get_field( 'main_site_url', 'option' ) );
    //* ACF Hooks and Filters
    include_once( get_stylesheet_directory() . '/lib/AcfExt.php' );
    

    where the acf function was called before the rest of the filters. All it took to fix was changing the order and the hooks fired again as expected

    (WORKING EXAMPLE)

    
    //* ACF Hooks and Filters
    include_once( get_stylesheet_directory() . '/lib/AcfExt.php' );
    define( 'MAIN_SITE_URL', get_field( 'main_site_url', 'option' ) );
    

    Hope this helps anyone else who has a random sync not showing up error

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.