Support

Account

Home Forums Backend Issues (wp-admin) ACF Fields disappear after selecting Category or Taxonomy

Solving

ACF Fields disappear after selecting Category or Taxonomy

  • Hey guys,
    I am using the latest version of ACF Pro and when I select a Category or a custom taxonomy on a post, the ACF fields disappear. All the data entered into those fields also doesn’t save once they’ve disappeared. I’ve looked at the older threads here that have some work arounds, but they don’t seem to working anymore. I’ve also tried switching to the latest free version of ACF but no luck there either. Any help would be greatly appreciated!

    Thanks!

  • When this happens it is usually an indication of a PHP error during the AJAX that fires when you select a category or term. The first thing to do is to deactivate other plugins. You need to track down where the error is happening and this can be difficult during AJAX requests. You’ll need to turn on error logging, see this for more information https://codex.wordpress.org/WP_DEBUG

  • Okay turning off the WPML plugin makes it work fine. There is nothing in the debug log though. Another interesting thing is that is only breaks for the secondary language. Everything is fine when editing any primary language post. I don’t have the option of keeping WNPL disabled, the site HAS to be multilingual! Do you have any idea what could be causing this problem?

    Thanks!

  • I’m not familiar with WPML. I do know that there is some type of an error happening that’s causing the AJAX request to break. This is usually an error in PHP, but may be an error in JavaScript. You need to track down what is interrupting the AJAX request.

  • In my case, deactivating Classic Editor Plugin solved the problem (I deactivated all the others). For some reason, ACF works fine with Guttenberg, but I’d like to use it with the classic editor. 🙁

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.