Home Forums Bug Reports ACF Create new post type bug


ACF Create new post type bug

  • hi. i created 3 post type last week, i had no issue.

    today i need one more (cpt: camp ), i created as usual, but i don’t see them .

    strange that i can see in acf post dropdown on the acf field group select options, but NOT in menu nor admin bar + > add new camp.

    what should i do now ?

  • solved: conflict with user role editor pro.

    when i import the cpt,
    i can glance the option at the + add camp.
    BUT once i save the cpt the menu disappear,
    i guess the url for the camp menu add post url and it prompt , you’re not allowed to create , need higher level permission,

    i am super admin, definitely its a bug with either acf pro or user role editor pro OR both.


  • I am having this issue and I do not have any plugins to manage or edit the menu or user roles installed. I can see that the custom post type was registered, but it does not show up in the admin menu (either the side nav or the bar). I did select the option to have it added.

  • OK, some additional information. I installed Admin Menu Editor to see what might be happening with this. Admin Menu Editor showed the menu as not visible. I then installed User Role Editor to see if there were missing permissions…and there are! In User Role Editor, if you turn on the deprecated options, you can see that none of the custom post type permissions are set. If you enable them, the menu appears.

  • WWow. Nothing from ACF on an April problem report. The same thing happened to me in September. Thanks to @gr33ngrl I tried the Admin Menu Editor. Nope. It doesn’t show at all for me.

    The CPT that I moved from CPTUI doesn’t show no matter what I put in Menu Position or Icon and save. Doesn’t show in Admin Menu Editor. Tried a test CPT and it shows up. Please, please address this issue; I need to access my CPTs from the menu.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.