Support

Account

Home Forums Backend Issues (wp-admin) ACF conflict with Visual Composer plugin

Solving

ACF conflict with Visual Composer plugin

  • Hi Support,

    I have a situation where my client has built a couple pages using your ACF plugin and has recently installed the Visual Composer plugin for the rest of their content/pages.

    The problem: We are experiencing a conflict between the two plugins where the ACF plugin will disable the editing capability of the VC plugin. Once you disable the ACF plugin th VC works fine (allows you to edit content normally) but, if you have the ACF enabled the VC will not allow normal editing. It shows text tab only and won’t save and in some cases dispersal all together during editing.. However, everything on the front-end works fine. There is no conflict when it comes to the user experience while browsing the website. The only issue is within the dashboard while editing.

    Have you heard of this issue? Do you have any insight as to what might be causing the conflict? And, do you have any suggestions as to how to solve the conflict?

    Thanks a lot!
    Please let me know if you need a login or site access.

  • I also have problems with the combination of ACF and VC. When I try to embed media in the WYSIWYG editor, the media doesn’t get inserted into the editor unless I click inside the editor quickly after clicking the blue insert media button in the media library.

    I can deal with it, but my customers can’t.

    It would be helpful if you could fix it.

  • Hello, the same for me – “Add Media” button does not work. Please solve this as soon as possible. Thanks.

  • Looks like the developer is ignoring this issue. If it is not solved, i am going to switch themes and avoid ACF.
    I rarely run into js conflicts and in this case it seems to be poor coding issue as VC works with all of our other themes and they are modern themes.

  • I came onto the forum to figure out why my repeaters are messed up, and your post had me try disabling VC…and that was issue!

    Screenshot of issue

    Any idea how to fix just this issue and run VC and ACF at the same time?

    I can turn repeaters to Row view rather than tables, and that seems to fix it….but for this and others Table is so much better.

  • After a bit of sleuthing and procrastinating about going to bed I figured out my issue…VC’s admin-side CSS was messing with the table since it has class=”row” inside it.

    js_composer/assets/css/ files:

    • js_composer.css
    • js_composer_backend_editor.css
    • js_composer_settings.css

    They all have .row:before, .row:after {content: “”; display:table} and for whatever reason it kills the table in ACF. I’ve commented out these classes on all 3 and we’ll see how she goes!

  • Thanks to adamepp’s discovery, I added this to my functions file and fixed it:

    // Fix Advanced Custom Fields and Visual Composer CSS conflict
    function afc_vc_fix() {
    	echo '
    	<style>
    		.repeater .row:before,
    		.repeater .row:after {
    			display: auto;
    			content: none;
    		}
    	</style>';
    }
    add_action('admin_head', 'afc_vc_fix');
  • I registered just for this.

    I have these two installed:

    Advanced Custom Fields: Repeater Field Version 1.1.1
    WPBakery Visual Composer Version 4.3.5

    They don’t work together.

    As soon as AFC is activated, I am not able to save any text in RTE fields in VC. The users are not able to modify content on the page. Worse: After updating the whole text is removed and the text-field is blank.

    Also: The AFC plugin can not be deactivated! WP says “plugin deactivated” but AFC is still activated and I can click again on “deactivate” with no effect. Only renaming the folder via FTP does help.

    Can you please provide a fix for this?

    Thank you!
    Chris

  • @chrisprefect

    On a new site I just installed the latest 4.3.5 and 1.1.1 on WP 4.1 and I had the same problem as mentioned in my post above, with the rows shifting. I added the function created by @captaincoo1 and everything cleared up. I’m not having issues with saving fields.

    Be sure all your repeater elements have unique field names…maybe thats the problem?

    Then check it by disabling all your plugins, if the fields work add the plugins back 1 by 1. If all else fails restart your computer 😉

    edit: sorry if I misunderstood…you are having trouble saving in VC fields, or repeater fields?

  • Hello @adamepp

    Thank you for the fast reply.

    It is just the AFC plugin. renaming the folder with FTP makes the VC editor work again.

    Activating the AFC plugin gives me the same error again.

    Attached a screenshot with the js error just before I update the text field. The textfield will be empty after I close the editor window.

  • And as soon as I click the blue update button the text is gone.

    This only happens with AFC active.

    Do you know why I am not able to deactivate the AFC plugin in the plugin page?

  • The function code fix does NOT solve the original posters problem – the issue with tinyMCE editor always switching to Text mode and adding images getting all wonky.

    I am having the same issue with ACF and Visual Composer. As there is no apparent solution, I found an alternative solution – http://customfieldsuite.com/

    I just installed the plugin and it is not causing any issues that I can tell with VC, although I haven’t dug into the functionality.

    I don’t know if it’s poor form to post a different plugin here but if the developer isn’t looking into the problem we need a solution and this may be it.

  • Having issues with this as well.

    Initially was having same issue as OP described, but since upgrading Visual Composer to 4.4.3, any pages with ACF just return completely blank. [Edit: <– This may not be directly related to Visual Composer, will have to investigate further. However, still experiencing the OP’s issue.]

    Any news / progress on this on ACF end?

  • For more than one year that I look this solution and while it is not a substitute for ACF by Custom Field Suit only for compatibility with Visual Composer in the WYSIWYG editor.

    Is there anyone working in this fix?

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.