Home Forums Backend Issues (wp-admin) ACF causing 500 Error on one page only


ACF causing 500 Error on one page only

  • I have a page on a website I’ve been working on which uses a flexible content field to create a manageable table of upcoming holidays. The page has been working fine until very recently (last couple days) and has worked for all user types.

    When I try to load the wp-admin of the page, I get a 500 error; Failed to load Resource. ACF works fine when editing any other page, I can update and save them fine. The issue only occurs when attempting to edit as an editor, admin is fine. Also the page loads fine when ACF Pro is disabled.

    To take you through the steps:

    1. Page gives Failed to load resource error when editing as editor
    2. Page loads fine when ACF Pro is disabled
    3. ACFs work on every other page
    4. The ACF that’s causing the problem does not show up on other pages when I set it to
    5. Page loads when an admin user

    I’ve tried the php.ini stuff to no avail, but I am relatively new to this so I might have got it wrong.

    I haven’t found anyone with the same issue anywhere, so I’m posting it here.

    Any ideas?
    Thanks in advance

  • Hi @govinski

    Could you please use the debug mode to find any error messages on the page. This page should give you more idea about it:

    Could you also re-install ACF in your site? It’s possible that you have a corrupted file.


  • @acf-support Thanks for your answer, I’m now just getting a white screen. WP_DEBUG hasn’t done anything. Does it work on the wordpress back end? Nothing is shown either on the screen or in the log file.

    There is a lot of content in the fields, I don’t want to have to type it all in again if I can avoid it. Is there any way to back up what’s contained within the fields, along with the fields themselves? Or could that be what’s causing this?


  • Hi @govinski

    The 500 error is a general error. So, finding the main issue is hard. The best way to get a clue about this error is to ask your hosting for the PHP log file.

    Could you please create the same field group and test it on the other pages? You can check wp_postmeta table in your database and search the metadata related to that page.

    I hope this helps.

  • I’m facing exactly the same problem on two differents sites since one year. Today i found a solution which sounds a bit strange: try to delete the revisions.
    After deleting the revisions the user role editor can now editing the page again.
    Hope it helps.

  • I’m facing the same error with ACF version 6.0, deleting the post revisions works for me. Thanks Christian

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘ACF causing 500 Error on one page only’ is closed to new replies.