Home Forums General Issues ACF block in widget doesn't listen for changes


ACF block in widget doesn't listen for changes

  • Hi.

    I’m using WordPress 5.8.1 and ACF PRO 5.10.2.

    I’m facing an issue while trying to save changes in custom block which is placed in widgets. The blue button in corner is inactive after I make any changes to the content of the fields in this block.
    If I use original Gutenberg block (not a custom one) everything works fine. It works fine also when the mode of this block is not set to edit. After switching from visual to edit mode, then it listens for changes and the Update button is active.

  • Same problem on me. Changes don’t trigger widgets save button.

  • Same problem here.

    When block is set to edit, it is not possible saves the changes.

  • Thanks for the report. We’re aware of this issue – if you click any other widget or change field etc, it should trigger the re-render and make it saveable until we can get a proper fix released!

  • Same issue, but the problem appears to be larger than just not having the “Update” button be clickable. If I mess around in a core widget block, yes I can have the “Update” button be clickable again, but it doesn’t actually SAVE any of my changes in my ACF block (but the changes to the core block are updated).

  • Same issue as madtownlems.

    Any progress on this?

  • I have the exact same problem. It looks like this is a bigger bug then just for one website. Is this being worked on?

    To clarify, not only the edits are not saved, it also seems that saved fields are not registered itself or got lost after a widget save.

    Added: It seems that the following notice pops-up on ACF Pro 5.11.4:

    Notice: acf_get_value werd <strong>verkeerd</strong> aangeroepen. <strong>Advanced Custom Fields PRO</strong> - 
    We've detected one or more calls to retrieve ACF field values before ACF has been initialized. 
    This is not supported and can result in malformed or missing data. <a href="" target="_blank">Learn how to fix this</a>. 

    Maybe this has something to do with the widgets now rendered in a “Deprecated widget” container?

  • I’m seeing the same issue on multiple sites/environments as well, a workaround that actually worked for me was going to Appearance → Customize → Widgets instead of the dedicated Appearance → Widgets screen. It’s not ideal since the Widgets sidebar is so narrow in the Customizer, but at least it’s possible to save ACF block changes there!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.