Support

Account

Home Forums Backend Issues (wp-admin) ACF automatically translate some field names

Solving

ACF automatically translate some field names

  • I’m working on a WordPress not english and when I name a field: Date (in my language, it means Dates, that’s the plural for Date) and save, at the refresh the name is automatically changed to Data. So it seems that ACF change the detected english name to my language but in this case it’s an error.

    How can I disable this auto translation?
    Thanks

    p.s. this issue is not releated to any translation plugin (such as WPML)

  • Hi @donad

    Do you change the field name (not label) to something more safe like my_date? If not please try that. It might be that you’re encountering a clash due to the very generic field name.

  • Same here, if I have my WordPress installation in Spanish and I add fields in English some of them are automatically translated. I deduce that this translations come from WordPress main PO language because only common words are translated. Is it possible to avoid this?

  • hi @jonathan
    I’m having that problem on the Tab field that has no field name but only label. Sure, I can use a label like “My dates” but this doesn’t solve the problem if I had to use “Dates”!

  • Hi,

    Okay so I’ve done some testing and indeed it seems like the translations are coming from WP Core. I don’t think it’s currently possible to avoid this issue other than naming your fields something that does not exist in core.

    I will include @elliot in this conversation to see what his view on this is. I could imagine an additional option for the acf_settings() function where one could set the text-domain to a custom.

  • Hi @donad

    Elliot is a busy man (maintaining this plugin all by himself!) but I’m sure he’ll respond in time. I have assigned him to this topic so he have/will get notification of it.

  • Any news for this?

  • I have this problem too. It is really annoying. I am creating a back end plugin that is in English, but I am working in a German WordPress environment. The visible names of the fields get translated AND I DO NOT WANT THIS

    Would it be possible either to have an option somewhere to suppress this, or a notational mechanism to get around it?

  • Hi @david-christie et al.,

    I’m gonna create a github issue for this since it does not seem like Elliot has the time to check the forums at this point.

    I know he’s more active with issues there as they are curated 🙂

    I’ve been looking through *alot* of the source code but can’t seem to find where the translations are applied to the field names thus I can’t comment on any current possibility to override this.

  • Hi Jonathan

    I have a feeling that this might have been fixed in the meanwhile. It seems to have got better in any case.

    Thx D

  • Oh, maybe it’s been fixed in a later version then 🙂

    I haven’t paid that much attention to the logs lately and as you can see have been slacking off in the forums 😉

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.