Home Forums Backend Issues (wp-admin) 502 bad gateaway


502 bad gateaway

  • Hi, when I try open “options” tab I get error 502 bad gateway. I have tried to update plugin but it is not working after update. Firstly, I do not see ‘options’ tab any longer and previously created field are broken because it can’t find repeated field and give me option to buy it ??!! Why should I pay agian? Why can’t I use plugin any longer?


    Plugin Version
    WP version 3.8.1

  • Hi @paska72

    Sorry to hear you are having issues, but the above is very confusing.
    You are having trouble using the options page?
    What does this have to do with purchasing the add-on again?
    What code are you using to register sub pages?


  • Ok, when I try to open /wp-admin/admin.php?page=acf-options I get 502 bad gateway. I have tried to update your addon. Now I can’t access to /wp-admin/admin.php?page=acf-options, I get You do not have sufficient permissions to access this page. but I also do not see tab options now. It seems update process uninstalled options and repeater plugins. I have installed them again but I can’t open options page. I can PM admin access to the staging system.

  • Hi @paska72

    Yes, can you please reply below with your login details. Just mark the reply as private.


  • This reply has been marked as private.
  • are you able to see login info?

  • Hi @paska72

    I have logged in and can see the issue.

    Firstly, can you please contact wpengine and ask them to take a look at the issue. I believe this is a server issue not related to ACF.

    Whilst you wait for their reply, can you answer the follow q’s?
    1. Has the options page eve worked on this install?
    2. Do any other areas of the site cause a similar server error?
    3. Have you attempted to disable all plugins to test?
    4. Have you attempted to swap to default theme?


  • Hi, thank you for your replay, sorry for pushing, have this error on the live server and need to solve it asap.

    I have contacted wpengine support they said its plugin issue and need to update it. I will contact them again

    Answer for your questions.

    1. Yes, it was working fine and just stopped to work when I added the new field.
    2. There is no other areas with this error
    3. I didn’t try that, fill free to do that on staging server
    4. I didn’t try to swap to default theme

  • Hi @paska72

    What field did you add? Perhaps it contains an inifinate loop which is breaking the page?

    Can you please delete any field group which appears on the options page?
    Does this fix the issue?

    perhaps your field group has become corrupt somehow?


Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘502 bad gateaway’ is closed to new replies.