Support

Account

Home Forums Bug Reports 5.7.6 Upadate caused all fields and data to disappear

Solved

5.7.6 Upadate caused all fields and data to disappear

  • Hello,
    I just updated the ACF plugin to 5.7.6 and now all my data has disappeared.

    https://brcja.brandzbox.com

    The plugin is also prompting for a database update.
    (I have not done this because – not sure what to do here).

    Is there a way to roll the plugin back?
    Is there a way to retrieve the data?

    Thanks in advance.

  • Hi! The same exact thing happened to me. All of the staff on our staff page have disappeared after doing this update.

  • Hello – I have reached out to support and am praying all data is not lost :-).

    I filled out this support form:
    https://www.advancedcustomfields.com/contact/

    And got a reply back…but my questions were not fully answered, so afraid to apply the updates.

    If I hear back with solution I will post it here!

    You might want to reach out to support as well.
    And reference this thread.
    This thread is the ‘Community’ forum.

    Thanks for posting.
    I am certain ACF can fix this as they are top-notch!

  • The same thing happened to me as well this AM. I am also getting the update database notice.

    Is there a way to roll the plugin back?

    Has anyone tried to reach ACF on Twitter?

  • I have not.

    I filled out this support form:
    https://www.advancedcustomfields.com/contact/

    And got a reply back…but my questions were not fully answered, so afraid to apply the updates.

    Maybe you can reach out as well and post this thread.

    Thanks!

  • for anyone that is having issues with updating ACF. First, roll back to ACF 4 and then contact support https://www.advancedcustomfields.com/contact/

  • Hi John,

    Thanks so much!!

    How do we roll the plugin back to ACF V4?

  • At the bottom of this guide are links to troubleshooting tips that includes how to roll back to version 4 https://www.advancedcustomfields.com/resources/upgrade-guide-version-5/

  • Thanks so much John!

    I do have a dumb question…

    Do I need to do this via FTP or my File manager?
    Can I just upload the new plugin?
    (Sorry – but have not done this before!)

    I found the WP Rollback Plugin. Would this work?
    https://wordpress.org/plugins/wp-rollback/

    I found this:
    Can I roll back?
    Yes, although it is a manual process. All versions of the ACF plugin can be found here. Simply download, extract and replace your ‘plugins/advanced-custom-fields’ plugin folder

    Thanks again!

  • That rollback plugin is one of the options listed. If you don’t want to mess with FTP then I’d try that.

    I you download from the other URL then you’ll need to upload manually. Basically you need to connect with FTP and delete the acf folder from your plugins and then upload the older version.

    Rolling back to version 4.0

    If you’d like to go back to an earlier version of ACF, we recommend using this rollback plugin, which is available from the WordPress repository. Once installed, use the Dashboard > Plugins page to Rollback the ACF plugin.

    Alternatively, you can rollback manually by downloading an older version of ACF and uploading it to your server via your favourite FTP application. Replacing the ACF plugin folder will not affect your data in any way and is a completely safe way to rollback

  • John – All fixed!!

    All I had to do was run the DATABASE UPDATER…

    Thanks again,
    Jean

    • Elliot

    • September 18, 2018 at 10:19 am

    Hi guys.

    Once you update to version 5 you will be prompted for a Database Upgrade. ACF 5 will configure some settings and ready your fields. https://www.advancedcustomfields.com/resources/upgrade-guide-version-5/

    Please be sure to run the DB Upgrade, otherwise, your fields will not appear.
    Hope this helps.

    Thanks
    Elliot

    • aila

    • September 27, 2018 at 10:47 pm

    I updated to version 5. I have a WP multisite. The old fields are still showing but in articles and posts there is no fields for input anymore. I have also updated the database 🙁 Is it the only way to go back to version 4?

  • I would roll back to V4 and try again. There are instructions for doing this here https://www.advancedcustomfields.com/resources/upgrade-guide-version-5/#troubleshooting

    With a multisite install you could be running into an issue where there’s too much data to process. You could also be running into an issue where all of the sites are not actually getting updated, but I’m not sure about this.

    If you’re still having issues contact support here https://www.advancedcustomfields.com/contact and they will try to help you with your issue.

    • oxyplay

    • October 6, 2018 at 4:47 am

    Same issue after updating to 5.7.7. Can’t get options page repeater field, other fields are working (not tested all. but at least image, textarea, text).
    Reverting to 5.7.6 – not fixed issue, only reverting to 5.7.5 fixed!

  • Has there been a fix released for this? I updated and lost all my images on the front end. I rolled back to a backup I had an it fixed the issue. I did not need to go to version 4 for this and was already on version 5. If there has not been a fix released for this please reopen.

  • I don’t know what could cause this. You might want to contact support https://www.advancedcustomfields.com/contact/

  • Well it’s not solved so maybe someone should mark it as an issue.

    On my client’s site, after the update all the advanced custom fields with images lost their values and I had to roll back.

  • I ran into similar issues when I updated several sites from 4.X to both 5.7.6 and subsequently 5.7.7. I assumed I had found a bug, but after struggling with a fix for longer than I care to admit, I found that the problem was an ACF hook that had been completely removed from a past release.

    A few of my themes and plugins registered custom fields programmatically with a call to register_field_group hooked into the acf/register_fields action. Apparently the acf/register_fields action was removed from ACF after 4.X, but I, like many others, was never prompted to update to ACF 5.X until very recently, even though it appears to have been in production for years now.

    Looks like others here may be suffering from a different issue, but for anyone whose fields have disappeared from the backend after a recent move from 4.X to 5.X, search your theme or plugin for any functions that hook into the acf/register_fields action. Move those to something like the acf/init action instead.

    While my field groups are all pretty simple without any conditional logic or anything, this fix worked for all of my themes and plugins. The same solution might not work for themes or plugins with complex field groups if a lot has changed between 4.X and 5.X.

    • oxyplay

    • January 4, 2019 at 1:40 am

    Still got this issue in 5.7.9.
    Repeater field from options page return nothing. Reverting to 5.7.5 fixes everything.
    Could you mark this topic as unresolved.

  • I had the same issue after updating from 5.6.x (can’t remember) to 5.7.9. I did two things, and suddenly the issue was resolved:

    1.Exported the field group I was most concerned with
    2.Reset permalinks

    After that, everything works as before.

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.