Support

Account

Home Forums Bug Reports 406 Error when saving field with url

Solving

406 Error when saving field with url

    • hein

    • October 4, 2014 at 4:07 am

    Hello there.

    Im getting this error and is driving me nuts…

    – addon domain on goddady
    – Brand new wordpress installation
    – acf pro developer edition
    – blank theme (index.php, style.css and functions for activating option page)

    – created the options page
    – added a group field to the options page
    – added a url field to the options page group field

    and when trying to save the options page, get the 406 error…

    “406 Not Acceptable

    An appropriate representation of the requested resource /web/wp-admin/admin.php could not be found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

    im guessing its a server related problem… but have no clue what might be…

    any ideas?

    thakns and greetings.

    Note: problem only occurs with acf pro, width acf + option plugin no problem at all.

    Note: this problems dont occur on another server i have access to, so that would point out that is really a server related problem.

    the mayor differences between both servers:

    the problem server does NOT have:
    – curl ipdv6 activated
    – pdo_mysql installed
    – pdo_sqlite installed
    – pdo drivers installed
    – zend guard enabled
    – WDDX Session Serializer enabled
    – ionCube Loader module
    – Internationalization support itnl

    the problem server has:
    – bzip2

    GOOD SERver: ‘./configure’ ‘–disable-fileinfo’ ‘–enable-bcmath’ ‘–enable-calendar’ ‘–enable-exif’ ‘–enable-ftp’ ‘–enable-gd-native-ttf’ ‘–enable-intl’ ‘–enable-libxml’ ‘–enable-mbstring’ ‘–enable-pdo=shared’ ‘–enable-soap’ ‘–enable-sockets’ ‘–enable-wddx’ ‘–enable-zip’ ‘–prefix=/usr/local’ ‘–with-apxs2=/usr/local/apache/bin/apxs’ ‘–with-curl=/opt/curlssl/’ ‘–with-freetype-dir=/usr’ ‘–with-gd’ ‘–with-gettext’ ‘–with-icu-dir=/usr’ ‘–with-imap=/opt/php_with_imap_client/’ ‘–with-imap-ssl=/usr’ ‘–with-jpeg-dir=/usr’ ‘–with-kerberos’ ‘–with-libdir=lib64’ ‘–with-libexpat-dir=/usr’ ‘–with-libxml-dir=/opt/xml2’ ‘–with-libxml-dir=/opt/xml2/’ ‘–with-mcrypt=/opt/libmcrypt/’ ‘–with-mm=/opt/mm/’ ‘–with-mysql=/usr’ ‘–with-mysql-sock=/var/lib/mysql/mysql.sock’ ‘–with-mysqli=/usr/bin/mysql_config’ ‘–with-openssl=/usr’ ‘–with-openssl-dir=/usr’ ‘–with-pcre-regex=/opt/pcre’ ‘–with-pdo-mysql=shared’ ‘–with-pdo-sqlite=shared’ ‘–with-pic’ ‘–with-png-dir=/usr’ ‘–with-tidy=/opt/tidy/’ ‘–with-xmlrpc’ ‘–with-xpm-dir=/usr’ ‘–with-xsl=/opt/xslt/’ ‘–with-zlib’ ‘–with-zlib-dir=/usr’

    BAD serveR:
    ‘./configure’ ‘–enable-bcmath’ ‘–enable-calendar’ ‘–enable-exif’ ‘–enable-ftp’ ‘–enable-gd-native-ttf’ ‘–enable-libxml’ ‘–enable-mbstring’ ‘–enable-pdo=shared’ ‘–enable-soap’ ‘–enable-sockets’ ‘–enable-zip’ ‘–prefix=/usr/local’ ‘–with-bz2’ ‘–with-curl=/opt/curlssl/’ ‘–with-freetype-dir=/usr’ ‘–with-gd’ ‘–with-gettext’ ‘–with-imap=/opt/php_with_imap_client/’ ‘–with-imap-ssl=/usr’ ‘–with-jpeg-dir=/usr’ ‘–with-kerberos’ ‘–with-libdir=lib64’ ‘–with-libexpat-dir=/usr’ ‘–with-libxml-dir=/opt/xml2’ ‘–with-libxml-dir=/opt/xml2/’ ‘–with-mcrypt=/opt/libmcrypt/’ ‘–with-mysql=/usr’ ‘–with-mysql-sock=/var/lib/mysql/mysql.sock’ ‘–with-mysqli=/usr/bin/mysql_config’ ‘–with-openssl=/usr’ ‘–with-openssl-dir=/usr’ ‘–with-pcre-regex=/opt/pcre’ ‘–with-pdo-mysql=shared’ ‘–with-pdo-sqlite=shared’ ‘–with-pic’ ‘–with-png-dir=/usr’ ‘–with-tidy=/opt/tidy/’ ‘–with-xmlrpc’ ‘–with-xpm-dir=/usr’ ‘–with-zlib’ ‘–with-zlib-dir=/usr’

    Any idea of what could be the problem?

  • I’m having this same issue and it’s driving me absolutely nuts. Tried changing them to text fields, deleting and re-creating the options page, changing field labels/names – nothing works.

    The thing is, every other field works and I can save the page just fine. It’s only when I input text into those trouble fields and hit update that it throws the error.

    I can only guess it has to do with the text and/or url field in the options page.

    Any help here would be much appreciated, Elliot. I’m fresh out of ideas. Thanks for all the hard work.

    • Jayson

    • October 11, 2014 at 10:57 am

    Meeee toooo!

    PS I/WE love ACF 🙂 Its what pays our rent!

    • kkyang

    • October 22, 2014 at 9:10 am

    I’m having this issue as well.

    • kkyang

    • October 23, 2014 at 2:56 am

    I came to this conclusion/problem as well after banging my head against the desk for hours.

    http://support.advancedcustomfields.com/forums/topic/options-page-not-working-with-godaddy/

    • kkyang

    • October 23, 2014 at 3:16 am

    I found a work around for this.

    Save the URL’s as “www.google.com” instead of “http://www.google.com” then in your theme change it to

    http://pastebin.com/GZWLBTkT

  • You must use a text field not a URL field and use the HTML escape characters for the colon (:).
    This is something that definitely needs to be fixed because you can’t have a URL field without the http://

  • The HTML escape characters for the colon is ampersand hash tag 5 8 semi-colon. { & # 5 8 ; } without the curly braces or spaces in-between.

    • Neal

    • October 24, 2014 at 1:32 pm

    The solution I found was to do this in the theme:

    <a href="http://<?php the_field('url');?>">...</a>

    and DON’T type

    http://
    into any field in ACF and you’ll be fine.

  • Having same issue here.

  • Exactly the same issue on one site.

    • Elliot

    • December 12, 2014 at 10:22 am

    Hi guys

    This is a super strange issue. More so that it is only with godaddy hosting.
    Has any one contacted godaddy to ask them for server errors to find out why a posted URL is causing such an issue?

    Thanks
    E

    • Darren

    • December 22, 2014 at 10:36 pm

    I have this issue as well, and I’m not hosted with GoDaddy. If I put a “http://” in a text field or URL field I get a 403 Forbidden and a 404 Not found error.

  • Hi guys,

    I got the same issue 406.
    I did contact the godaddy support. They said the domain hitting the mod sec.
    So they disabled the mod sec.

    Now my site is working good.
    Hope this can help.

    • jmccall

    • December 17, 2019 at 6:01 am

    Did anyone ever figure out what was going on with this issue? I have a client with Bluehost and I’m getting a similar error:

    Not Acceptable!
    An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

    I get in an options panel for a url field. Oddly enough, other url fields within that panel update just fine. But the three on this tab do not.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.