Support

Account

Home Forums Backend Issues (wp-admin) 403 on field update

Solving

403 on field update

  • He,

    been goin through some of the posts on forum here and didn’t find any close to the matter. So, several months ago I’ve setup a page for my client relying heavily on ACF Pro. Everything worked like a charm. Fast forward to one month ago, he asked me to move all of his stuff to another hosting – that went well too. Fast forward again, today I was asked to update just one thing, just some random quote string to be displayed on the front. Everything was already setup previously, typed it, clicked Update and boom, 403  Forbidden | nginx

    Tried that several times, went to debug.log (no info there). All the fields are grouped up by pages, I’ve discovered that on some of them Update option works just fine whereas on the others I’m getting 403. Been trying to find out what’s the cause for that but I’m kinda stuck, not sure even where to look for the info.  

    All of the fields are working just fine (functionally), all the data is there. It’s just, some of it cannot be updated. Any ideas? Is there any way to check up what’s wrong with the given field? Shouldn’t the debug.log provide some basic info? is it just hosting related (mod_security?)

  • By any chance, does this contain a URL field?

  • I would say that there is something in a firewall on the server that is doing this. You need to narrow down what type of field and what the content is that is causing it. Then you can have a discussion with the hosting company to find a solution.

  • hello, thanks for replies – well, stuff indeed was connected to WAF (web application firewall) issues. turning off some of the features on the host side restored all functionality.

  • Having this same issue. Can you please mention specifically what fixed it?

  • For anyone else having this issue I was able to fix it by disabling “ModSecurity” in cPanel under “Security”

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.