Support

Account

Home Forums Add-ons Options Page 1.1.0 Update Loop

Solved

1.1.0 Update Loop

    • mrwweb

    • July 16, 2013 at 6:38 am

    In two different environments, I updated the Options Add-on to 1.1.0 and it keeps asking me to update again. Any idea if this is a bug or something I need to do on my end?

    • Elliot

    • July 16, 2013 at 2:48 pm

    Hi @mrwweb

    Thanks for the feedback, I’ll look into it.

  • I noticed this too, this is displayed on my update screen: You have version 1.1.0 installed. Update to 1.1.0. View version 1.1.0 details.

    Updating doesn’t do anything, the message remains.

    • Elliot

    • July 17, 2013 at 3:05 pm

    Hi @steve Holland

    What if you update again. There should be a link to do try again?

  • It doesn’t go away regardless of how many times I press update.

    Downloading update from http://download.advancedcustomfields.com/…
    Unpacking the update…
    Installing the latest version…
    Removing the old version of the plugin…
    Plugin updated successfully.

    After this message I go back to Dashboard > Updates and it’s there again.

    I’ve even tried downloading the plugin from your website and installing version 1.1.0 manually via FTP. It says there’s is an update to 1.1.0 even though I am using 1.1.0.

    • Elliot

    • July 18, 2013 at 12:41 pm

    Hi @steve Holland

    Thanks for the info. Are you able to help find the issue by debugging?

    Can you open up the uploader file and on line 78, test the value of $this->settings[‘version’].

    This should be the version number that is written in the plugin file on line 6

    Is the version correct?

  • Are you referring to the following line on 77 in acf-options-page-update.php?

    $this->settings['version'] = $plugin_data['Version'];

  • I was having this issue but I haven’t had it in a bit now. Was it server-side?

  • I checked the variables on line 77 of acf-options-page-update.php and they both return correctly, “1.1.0”.

    • Elliot

    • July 18, 2013 at 3:27 pm

    Hey guys,

    Thanks for the debug data,

    Perhaps the issue is further down in the update file in the ‘check_update’ function.

    Would you mind debugging that function. Perhaps there is an if statement which is not working…

  • Hey Elliot,

    I just experienced the same problem and did some debugging and found that $this->settings[‘version’] is an empty string on line 220 in the function named check_update.

    // compare versions
    if( version_compare($info->version, $this->settings['version'], '<=') )
    {
        return $transient;
    }

    The problem seem to be the if clause at line 70.
    if( $pagenow == 'plugins.php' )
    Because the user might not be on the plugins.php page the version in the settings array will not be set, and defaults to an empty string on line 36.

  • Yes, clicking the return to plugins page instead of the updates page ends the loop.

    • Elliot

    • July 20, 2013 at 12:11 pm

    Hi @circuuz

    Thanks mate! Great find. I’ll have this fixed and a new version released

    • Elliot

    • July 20, 2013 at 12:22 pm

    Hey guys,

    I think I’ve found and fixed the problem.

    If you are still experiencing the update promt, please update again, the new plugin downloaded should correctly tell WP about the new version and fix the issue.

    Let me know.

    Thanks
    Elliot

  • Hi Elliot,

    So sorry to be the bearer of bad tidings, but it’s still happening for me 🙁

    Looking forward to the fix!

    • Elliot

    • July 23, 2013 at 3:37 pm

    Hi @alexstanhope

    After the update, can you navigate to the Dashboard -> Updates and do a hard refresh.

    Does the add-on update go away?

  • Hi Elliot,

    Thanks so much for getting back to me; tried it, but the update notification is still there 🙁

    • Elliot

    • July 24, 2013 at 12:42 pm

    Crazy!

    How are you with debugging?

    Perhaps you can debug the acf-options-page/acf-options-page-update.php file?

    There is a function called check_update which you can debug the variables in. This function should match the versions and return $transient on line 211.

    Maybe you can find out why it is getting past that line? Or maybe it is another issue all together in that updater…

  • Just updated to 1.2.0 and same issue…

    Advanced Custom Fields: Options Page
    You have version 1.2.0 installed. Update to 1.2.0. View version 1.2.0 details.
    Compatibility with WordPress 3.5.2: Unknown

  • Hi again Elliot.

    I saw that you added the update.php string to the if clause on line 70 to so that the settings version is actually being set when we are checking for an update. Unfortunately you seem to have gotten the wrong $pagenow value, the correct value for $pagenow when your on the update page is update-core.php.
    When I now changed the string into update-core.php it no longer prompts you to update 🙂

    • Elliot

    • July 29, 2013 at 1:45 pm

    Hi @circuuz

    What a legend!

    Thanks mate

  • Hello,

    I’m still getting this update loop with 1.2.0, is circuuz’ fix in place?

    Thanks

  • I’m also still getting this in 1.2.0 but clicking the “Return to Plugins” link rather than the “Return to Updates” link after updating does cause it to go away.

  • I’m seeing this as well:

    Advanced Custom Fields: Options Page
    You have version 1.2.0 installed. Update to 1.2.0. View version 1.2.0 details.

    It only shows up sometimes. Like I’ll have a list of updates, run them, and then this one will show up afterwards, if I switch between the plugins page and the updates page sometimes it goes away for a bit, but seems to keep coming back. I’ve got it on a handful of different sites and a couple different hosts and seeing the same on all of them.

    Happy to help debug if needed.

    • Elliot

    • August 28, 2013 at 2:11 pm

    Hi guys.

    I have attempted to fix this issue as of the 28th of August.

    Can you please try again to update the plugin, the new files should resolve the issue.

    Let me know how you go.

    Thanks
    E

Viewing 25 posts - 1 through 25 (of 26 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.