Home Forums Backend Issues (wp-admin) Fields not showing since recent update Reply To: Fields not showing since recent update

  • @CCAZ wrote:

    I found a partial solution. I think that ACF is not recognizing custom types of posts/pages ( I’m not sure what correct terms are ) .

    We use a type of post called Project.

    When I toggled it to affect another group. saved. viewed. then toggled it back to Project – it appears to work now.

    Do you have custom post/template types?


    I originally rolled from 5.2.1 to 5.0 – and still experienced the problem. So I have been upgrading slowing, starting with it being stable on 4.8. I was surprised to find that this time, when I got to 5.0 it appeared to be working. At least, it was working on _Existing_ pages, I forgot to check creation of new items. My first thought was that it was necessary to do a major upgrade at a time ( 4.8 -4.9->5.0->5.1 )

    When I got to 5.1, I found existing pages were still working (!), and was excited my plan worked. However new pages, did not – they lacked the necessary custom forms.

    I went into ACF, and everything looked ok. So I tried assigning those fields to another type of post and it worked. When I toggled them back to “projects” now it works.

    I found this interesting – when I loaded up a project to review I saw this:

    There is an autosave of this post that is more recent than the version below.View the autosave

    When I compare the two I see that the “newer” version ( a draft that was saved during the upgrades ) lacks the custom fields.

    So my best guess is that ACF is not honoring the existing rules, and they need to be reassigned.

    I’m running on 5.2 right now, and that’s good enough for the short term. I’ll mess with it more after the conference I’m supposed to be prepping for 🙂

    Have you found the most recent version of WP that yours works on correctly?