Home Forums ACF PRO The update from 5.0.5 to 5.0.6 is not working – update not available Reply To: The update from 5.0.5 to 5.0.6 is not working – update not available

  • hmmm it was possible to update custom post type ui to version 0.8.4 yesterday. On Safari the error was a bit different. Package not available hasn’t showed up. instead the update plugin took felt forever (also for cpt ui). I then clicked on the dashboard again. In the case of cpt ui the plugin was updated anyway in the case of acf never. no matter how long i let the updater work.

    the failing update differs from safari and chrome. safari on the right and chrome on the left.

    about the things i tried aside. I let the background update tester run. it passes all tests without a fail. i also tried to install a new plugin. that also works.

    i switched on debugging in wp-config but no errors or warnings show up. i tried to add also define( 'FS_METHOD', 'direct'); like a friend suggested but that also hasn’t any effect. i’ve checked the network pane in the chrome dev tools while updating but also no errors showed up. Then i remembered one thing. The site is hosted on 1&1. They don’t allow gzip compression so you have to use zlib. therefor a php.ini file has to be in every folder (also in plugins). They are placed as symlinks to the original in the root. the php.ini contains

    zlib.output_compression =1
    zlib.output_compression_level =9
    error_reporting = E_ALL | E_STRICT
    log_errors = On
    display_errors = Off
    error_log = /homepages/4/d54545454545/htdocs/php-errors.log

    (i’Ve altered the path of the error_log for demonstration purpose in public here 😉 )

    so i’ve deleted every php.ini symlink in the acf folders too as well as the one inside the root of the plugins folder. but still the same effect – the update doesn’t work. Now i am a bit out of ideas how to debug things a bit further. :((( Is it maybe a permissions issue of acf files and folders???? cuz i’ve manually downloaded and replaced the present version (it’s 5.0.5x – you recommended updating manually to fix a few js issues a few days back). Best regards Ralf