Home Forums General Issues ACF version downgrades to 5.9.5 after migration! Reply To: ACF version downgrades to 5.9.5 after migration!

  • @hube2

    I’ve already tried doing that with customer support in the beginning. They gave me a plugin to troubleshoot it with a safe mode which deactivates all plugins except for the ACF Pro. I did manually deactivate each one apart from the plugin as well, but no change. The same issue persists. I’ve also tried manually reinstalling the proper version from a new zip file from the ACF account (v., but it only seems to show the version on the plugin list itself while also still prompting me to update to the latest version. Even though it says I’ve already updated it. However, if I go to ACF > Updates to check the version it still says 5.9.5 and the UI doesn’t update to the new interface. I can keep pressing update too, it just won’t. It says it has been, but again no change apart from the plugin list, but the prompt still loops.

    I’ve also tried deactivating, and uninstalling ACF Pro to just try to reinstall it, but for some reason even if I check cPanel and the plugins folder to make sure that the plugin doesn’t exist, I can still see it on the WP dashboard sidebar. I can still access it and everything, but the Updates option is now not available unless I reinstall and reactivate it. Which still doesn’t change the version no matter which version I upload. I was using 6.1.7 originally. I’ve tried re-entering the license key too. No dice.

    I am using Divi if that matters. It’s just confusing because if it was a plugin that was causing this issue, wouldn’t the same issue be replicated on my staging sites? I’ve already tried migrating the same file to a brand new WP installation on a new staging site and I can’t replicate the issue. It only happens on the live site which uses a different host provider and MariaDB. My host provider uses MySQL. They should be compatible for the most part, but I haven’t been able to find anything that works.

    My inclination is to believe that it has something to do with the database, but as I’m more a front-end developer than a back-end one, messing too deeply with those files without knowing full-well what I’m doing seems too risky. Any other ideas on what I could try to figure out why this might be happening?

    The only thing I can think of to try is removing everything from the public_html folder getting a brand new install of WP again and trying the migration one more time.