Home Forums General Issues ACF version downgrades to 5.9.5 after migration!


ACF version downgrades to 5.9.5 after migration!

  • I’m using ACF Pro, and when I’ve migrated my site from a staging environment on a subdomain to the live site, the ACF plugin reverts from the latest version ( to 5.9.5.

    No matter how much I update it within the plugin list, the plugin itself or even manually updating it by uploading the zip file with the new version the old one persists.

    With updating it keeps asking me to update to the newest version on the plugin list, but it says it’s been updated, but in ACF it states that it is using 5.9.5. I’m at a loss of what to do. I’ve used Duplicator Pro to do the migration and nothing seems to work.

    I’ve been in contact with customer support, but I have yet to gain a solution to this issue. It’s for a client and I have made many custom fields and a CPT with it’s own taxonomies and all that disappears after migration to the live site. I’ve migrated to a fresh install on a new subdomain and there have been no issues thus far.

    Do you think it’s because I’m migrating from MySQL (subdomain) to MariaDB (live site)? I have not encountered this issue before and I don’t know what else to try. I looked into the DB and posts seem to be there too, but again the plugin reverts so none of my fields or the CPT menu shows on the sidebar in the dashboard either.

    Would I have to just delete the entire contents of public_html to do a hard reset install WP and do the migration from there? I don’t know what I would even need to delete in the DB to remove whatever is causing this issue.

    Please advise, I’m fairly new with this plugin and am not backend savvy so I’d prefer to not go directly into the php files if I can help it. Any insight into this issue would be greatly appreciated!!

  • Oh I forgot to add, when deactivating and deleting the plugin to try to reinstall, the plugin menu for ACF is still on the sidebar! Just the “Updates” options is removed for it, but I’m still able to go into the plugin. I checked the plugins folder too, it really has been removed.

  • You have ACF included in another plugin, more than likely a plugin. It could be in the theme but what you describe seems like it’s in a plugin.

    Look at your other plugins and figure out which one includes ACF. Deactivate and reactivate that other plugin. This might help because it will alter the order that plugins are loaded.

    You also need to get an updated version of the plugin causing the issue or ask that plugin author about an update.

  • @hube2

    I’ve already tried doing that with customer support in the beginning. They gave me a plugin to troubleshoot it with a safe mode which deactivates all plugins except for the ACF Pro. I did manually deactivate each one apart from the plugin as well, but no change. The same issue persists. I’ve also tried manually reinstalling the proper version from a new zip file from the ACF account (v., but it only seems to show the version on the plugin list itself while also still prompting me to update to the latest version. Even though it says I’ve already updated it. However, if I go to ACF > Updates to check the version it still says 5.9.5 and the UI doesn’t update to the new interface. I can keep pressing update too, it just won’t. It says it has been, but again no change apart from the plugin list, but the prompt still loops.

    I’ve also tried deactivating, and uninstalling ACF Pro to just try to reinstall it, but for some reason even if I check cPanel and the plugins folder to make sure that the plugin doesn’t exist, I can still see it on the WP dashboard sidebar. I can still access it and everything, but the Updates option is now not available unless I reinstall and reactivate it. Which still doesn’t change the version no matter which version I upload. I was using 6.1.7 originally. I’ve tried re-entering the license key too. No dice.

    I am using Divi if that matters. It’s just confusing because if it was a plugin that was causing this issue, wouldn’t the same issue be replicated on my staging sites? I’ve already tried migrating the same file to a brand new WP installation on a new staging site and I can’t replicate the issue. It only happens on the live site which uses a different host provider and MariaDB. My host provider uses MySQL. They should be compatible for the most part, but I haven’t been able to find anything that works.

    My inclination is to believe that it has something to do with the database, but as I’m more a front-end developer than a back-end one, messing too deeply with those files without knowing full-well what I’m doing seems too risky. Any other ideas on what I could try to figure out why this might be happening?

    The only thing I can think of to try is removing everything from the public_html folder getting a brand new install of WP again and trying the migration one more time.

  • MySQL vs MariaDB should have no affect.

    The reason I recommended what I did was your second post

    Oh I forgot to add, when deactivating and deleting the plugin to try to reinstall, the plugin menu for ACF is still on the sidebar! Just the “Updates” options is removed for it, but I’m still able to go into the plugin. I checked the plugins folder too, it really has been removed.

    This tells me that ACF is still installed somewhere that you don’t see it. This happens when ACF is installed as part of the theme or included on another plugin. If updates are not available this would also indicate that the free version of ACF is what is included, wherever it is included.

    I do not think it is in the theme though because plugin are loaded first which should prevent the plugin in the theme from running.

    In any case, for this to happen the ACF files have to exist and be loaded, so they are there somewhere, you just need to locate them.

    The only other explanation could be that it’s installed as a mu-plugin, which I find highly unlikely, but not impossible.

  • @hube2

    The MU-Plugins! I think that might be it. I just checked the list on dashboard and there acf-builder.php, but there’s also ACF Pro there and it’s the old version! So it’s being overridden by that. Can I just delete the ACF Pro in the mu-plugins folder in File Manager to get rid of this issue then? What about the acf-builder.php abd acf-builder-1.11.0 folder?

    I removed the mu-plugins in my staging sites, I’m not sure why these were reinstated when I migrated over. Strange. Any thoughts on to why that is?

  • The only way to remove MU plguins in with FTP or a file manager or something like that. I can’t say how they installed ACF as a MU plugin, but you need to remove it from there. I would have to see the code used to include the ACF files.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.