Home Forums Bug Reports ACF Clone field in group not importing properly Reply To: ACF Clone field in group not importing properly

  • I’ve just had the same issue. I use a clone field for reusing colour choices across different areas of a site. (One client has 11 colours in their palette, so entering that in a select field each time I need it is a bit of a faff!)

    This had worked fine for me in the past:

    1. Create select field in a Sitewide Defaults group.

    2. Clone the field wherever needed.

    The clone field seems to import OK if it’s just a regular field, but causes a bug if it’s a sub field, such as in a flex or repeater field.

    In my case, the cloned field is converted to an equivalent regular field and triplicated.

    For example, I use “section” as the field name and enable the prefix fields option, so that the final field is used as “section_colour”.

    After import, I find three identical select fields called “section_colour”. Note, these are NOT clone fields but have been converted to a select field (as that’s the type for the base field which has been cloned)

    I then tried to remove the extra ones and resetting the clone relationship but on saving the field group the problem repeated. Three of the same converted fields again.

    I’ve never had this problem before. I’m using 5.11.4 on WP 6.0.3.