Home Forums Bug Reports WYSIWYG Error Reply To: WYSIWYG Error

  • I just encountered this same issue and cannot seem to fix it. No errors showing up in the Chrome console to indicate any kind of conflict or Javascript error. Stock standard theme with no other plugins installed except Advanced Custom Fields and my purchased premium addons.

    I am using the latest version of WordPress as well (auto-updated).

    I am trying to use the WYSIWYG editor inside of a Flexible Content Field. I’ve tried both full and basic modes for the toolbar, also enabling and disabling the media upload button.

    No formatting buttons seem to appear above the editor whatsoever. The formatting toolbar has vanished. Weirdly, if I say yes to having a media upload button, it does show, but it is the only button you can see. The content editor section itself is showing me HTML code, not the styled view you would usually expect from a WYSIWYG editor. It is acting like the text tab has been clicked as opposed to the default visual tab. It’s almost like the editor isn’t being applied at all.

    At first I thought maybe it was the Flexible Content Field functionality breaking the editor, but then I tried just adding in a standalone field and seeing if that worked, but the editor was also broken there as well. I also tried various combinations and embedding within the repeater field and whatnot.

    Is this a known issue? I couldn’t find much out there in regards to info or other people having this issue except this topic.