Home Forums Backend Issues (wp-admin) Field Groups not saving changes Reply To: Field Groups not saving changes

  • I got here after googling “acf fields won’t save to group” because I was having an issue where I could save a parent field, but couldn’t save any child fields to that parent group. I’d hit save and they’d appear as siblings of the parent group rather than children (subfields). While troubleshooting, I reinstalled ACF and this caused an additional symptom where it appeared the entire field group was empty, though it wasn’t– above the existing fields, it read “No fields. Click the + Add Field button to create your first field.”

    I ruled out plugin conflicts (deactivated all other plugins) and then used a default theme which solved the issue, so I temporarily renamed the functions.php and that did the trick. After combing through some functions– it was crammed with different customizations that probably should’ve been plugins, because younger me didn’t know what I know now– I saw there was one that removed query strings from static resources which set off my spider sense. I removed it and that solved the problem. The offending code:

    `//Remove query strings from static resources

    function _remove_script_version( $src ){
    $parts = explode( ‘?ver’, $src );
    return $parts[0];

    add_filter( ‘script_loader_src’, ‘_remove_script_version’, 15, 1 );
    add_filter( ‘style_loader_src’, ‘_remove_script_version’, 15, 1 );